CVE-2023-42810 systeminformation SSID Command Injection Vulnerability

Critical 9.8 Published Updated

Attackers can execute arbitrary commands via unsanitized SSID inputs in the systeminformation Node.js library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-42810?

CVE-2023-42810 is a critical command injection vulnerability in sebhildebrandt systeminformation, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

systeminformation is a System Information Library for Node.JS. Versions 5.0.0 through 5.21.6 have a SSID Command Injection Vulnerability. The problem was fixed with a parameter check in version 5.21.7. As a workaround, check or sanitize parameter strings that are passed to `wifiConnections()`, `wifiNetworks()` (string only).

Weakness: CWE-77

Which versions are affected by CVE-2023-42810?

2 open source packages ship an affected version, including systeminformation. It affects 1 product.

PackageAffectedFixed in
systeminformation npmFrom 5.0.05.21.7
systeminformation npmFrom 5.0.05.21.7

Products include Systeminformation Systeminformation.

How do I fix CVE-2023-42810?

Upgrade systeminformation to 5.21.7 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2023-42810 being exploited?

There is no known exploitation of CVE-2023-42810 in the wild and no public exploit code.

Sources

Also known as GHSA-gx6r-qc2v-3p3v.

Is CVE-2023-42810 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free