# CVE-2023-42817: Cross-site Scripting (XSS) in pimcore admin-ui-classic-bundle translations

> Attackers can inject malicious scripts via translation strings in the Pimcore admin UI, potentially executing code or bypassing security controls.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Sep 2023
- **Updated:** 24 Sep 2024
- **Also known as:** GHSA-m988-7375-7g2c

## What is CVE-2023-42817?

CVE-2023-42817 is a medium-severity cross-site scripting vulnerability in pimcore admin-ui-classic-bundle, published on 25 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Pimcore admin-ui-classic-bundle provides a Backend UI for Pimcore. The translation value with text including “%s” (from “%suggest%) is parsed by sprintf() even though it’s supposed to be output literally to the user. The translations may be accessible by a user with comparatively lower overall access (as the translation permission cannot be scoped to certain “modules”) and a skilled attacker might be able to exploit the parsing of the translation string in the dialog box. This issue has been patched in commit `abd77392` which is included in release 1.1.2. Users are advised to update to version 1.1.2 or apply the patch manually.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-42817?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.1.2 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.1.2 |

Products: Pimcore Admin Classic Bundle.

## How do I fix CVE-2023-42817?

Upgrade pimcore/admin-ui-classic-bundle to 1.1.2 or later.

## Is CVE-2023-42817 being exploited?

There is no known exploitation of CVE-2023-42817 in the wild and no public exploit code.

## Other vulnerabilities in pimcore admin-ui-classic-bundle

- [CVE-2024-23646](https://insights.sbomify.com/CVE-2024-23646/): Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip (high 8.8)
- [CVE-2024-23648](https://insights.sbomify.com/CVE-2024-23648/): Pimcore Admin Classic Bundle host header injection in the password reset (high 8.8)
- [CVE-2023-49075](https://insights.sbomify.com/CVE-2023-49075/): Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls (high 8.5)
- [CVE-2024-25625](https://insights.sbomify.com/CVE-2024-25625/): Pimcore Host Header Injection in user invitation link (high 8.1)
- [CVE-2025-24980](https://insights.sbomify.com/CVE-2025-24980/): Pimcore Admin Classic Bundle allows user enumeration (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42817 and fix it if it is affected.

What it is: CVE-2023-42817 is a medium-severity cross-site scripting vulnerability in pimcore admin-ui-classic-bundle, published on 25 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-42817 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.1.2
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42817/ (Markdown: https://insights.sbomify.com/CVE-2023-42817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42817
- OSV: https://osv.dev/vulnerability/CVE-2023-42817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42817/
Summaries are generated and may contain mistakes; the official description above is the record.
