CVE-2023-42917 Apple Multiple Products WebKit Memory Corruption

Exploited in the wild High 8.8 Published Updated

Memory corruption in WebKit allows arbitrary code execution when processing web content, affecting Apple operating systems and Safari.

Exploited in the wild
Since 4 Dec 2023
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-42917?

CVE-2023-42917 is a high-severity memory corruption vulnerability in Apple Ipados, published on 30 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A memory corruption vulnerability was addressed with improved locking. This issue is fixed in iOS 17.1.2 and iPadOS 17.1.2, macOS Sonoma 14.1.2, Safari 17.1.2. Processing web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been exploited against versions of iOS before iOS 16.7.1.

Weakness: CWE-787

Which versions are affected by CVE-2023-42917?

3 open source packages ship an affected version, including java, java-min and jre. It affects 7 products.

PackageAffectedFixed in
java BitnamiAll versions1.8.0, 8.0.411
java-min BitnamiAll versions1.8.0, 8.0.411
jre BitnamiAll versions1.8.0, 8.0.411
Linux distribution packages (27)
webkit2gtk3 AlmaLinux:8All versions2.40.5-1.el8_9.1.alma.1
webkit2gtk3-devel AlmaLinux:8All versions2.40.5-1.el8_9.1.alma.1
webkit2gtk3-jsc AlmaLinux:8All versions2.40.5-1.el8_9.1.alma.1
webkit2gtk3-jsc-devel AlmaLinux:8All versions2.40.5-1.el8_9.1.alma.1
webkit2gtk3 AlmaLinux:9All versions2.40.5-1.el9_3.1
webkit2gtk3-devel AlmaLinux:9All versions2.40.5-1.el9_3.1
webkit2gtk3-jsc AlmaLinux:9All versions2.40.5-1.el9_3.1
webkit2gtk3-jsc-devel AlmaLinux:9All versions2.40.5-1.el9_3.1
webkit2gtk3 Red Hat:enterprise_linux:8::appstreamAll versions0:2.40.5-1.el8_9.1
webkit2gtk3-debuginfo Red Hat:enterprise_linux:8::appstreamAll versions0:2.40.5-1.el8_9.1
webkit2gtk3-debugsource Red Hat:enterprise_linux:8::appstreamAll versions0:2.40.5-1.el8_9.1
webkit2gtk3-devel Red Hat:enterprise_linux:8::appstreamAll versions0:2.40.5-1.el8_9.1
webkit2gtk3-devel-debuginfo Red Hat:enterprise_linux:8::appstreamAll versions0:2.40.5-1.el8_9.1
webkit2gtk3-jsc Red Hat:enterprise_linux:8::appstreamAll versions0:2.40.5-1.el8_9.1
webkit2gtk3-jsc-debuginfo Red Hat:enterprise_linux:8::appstreamAll versions0:2.40.5-1.el8_9.1
webkit2gtk3-jsc-devel Red Hat:enterprise_linux:8::appstreamAll versions0:2.40.5-1.el8_9.1
webkit2gtk3-jsc-devel-debuginfo Red Hat:enterprise_linux:8::appstreamAll versions0:2.40.5-1.el8_9.1
webkit2gtk3 Red Hat:enterprise_linux:9::appstreamAll versions0:2.40.5-1.el9_3.1
webkit2gtk3-debuginfo Red Hat:enterprise_linux:9::appstreamAll versions0:2.40.5-1.el9_3.1
webkit2gtk3-debugsource Red Hat:enterprise_linux:9::appstreamAll versions0:2.40.5-1.el9_3.1
webkit2gtk3-devel Red Hat:enterprise_linux:9::appstreamAll versions0:2.40.5-1.el9_3.1
webkit2gtk3-devel-debuginfo Red Hat:enterprise_linux:9::appstreamAll versions0:2.40.5-1.el9_3.1
webkit2gtk3-jsc Red Hat:enterprise_linux:9::appstreamAll versions0:2.40.5-1.el9_3.1
webkit2gtk3-jsc-debuginfo Red Hat:enterprise_linux:9::appstreamAll versions0:2.40.5-1.el9_3.1
webkit2gtk3-jsc-devel Red Hat:enterprise_linux:9::appstreamAll versions0:2.40.5-1.el9_3.1
webkit2gtk3-jsc-devel-debuginfo Red Hat:enterprise_linux:9::appstreamAll versions0:2.40.5-1.el9_3.1
webkit2gtk3 Rocky Linux:8All versions0:2.40.5-1.el8_9.1

Products include Apple Ipados, Apple Iphone Os, Apple Macos, Apple Safari, Debian Debian Linux, Fedoraproject Fedora and 1 more.

How do I fix CVE-2023-42917?

Upgrade java to a fixed version for your release line: 1.8.0 or 8.0.411. US federal agencies must fix it by 25 Dec 2023.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2023-42917 being exploited?

Yes. Attackers have exploited CVE-2023-42917 in the wild since at least 4 Dec 2023.

All Apple Ipados vulnerabilities

Sources

Also known as ALSA-2023:7715, ALSA-2023:7716, BIT-java-2023-42917, BIT-java-min-2023-42917, BIT-jre-2023-42917, DEBIAN-CVE-2023-42917 and 13 more.

Is CVE-2023-42917 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free