# CVE-2023-42917: Apple Multiple Products WebKit Memory Corruption

> Memory corruption in WebKit allows arbitrary code execution when processing web content, affecting Apple operating systems and Safari.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 4 Dec 2023 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Nov 2023
- **Updated:** 21 Oct 2025
- **Also known as:** ALSA-2023:7715, ALSA-2023:7716, BIT-java-2023-42917, BIT-java-min-2023-42917, BIT-jre-2023-42917, DEBIAN-CVE-2023-42917, GHSA-phhr-cqm7-gjv6, MINI-37c3-v295-7pvh, MINI-3xj2-2hcw-m9w8, MINI-4r7x-c936-m7pr, MINI-6448-r5cq-h9mh, MINI-6mwf-fj63-vm4q, MINI-c95p-fv5v-jwwx, MINI-q66q-xc65-5jrc, MINI-w2r2-h6vj-vgjv, RHSA-2023:7715, RHSA-2023:7716, RLSA-2023:7716, UBUNTU-CVE-2023-42917

## What is CVE-2023-42917?

CVE-2023-42917 is a high-severity memory corruption vulnerability in Apple Ipados, published on 30 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A memory corruption vulnerability was addressed with improved locking. This issue is fixed in iOS 17.1.2 and iPadOS 17.1.2, macOS Sonoma 14.1.2, Safari 17.1.2. Processing web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been exploited against versions of iOS before iOS 16.7.1.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2023-42917?

3 open source packages ship an affected version, including java, java-min and jre. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.8.0, 8.0.411 |
| `java-min` | Bitnami | All versions | 1.8.0, 8.0.411 |
| `jre` | Bitnami | All versions | 1.8.0, 8.0.411 |
| `webkit2gtk3` | AlmaLinux:8 | All versions | 2.40.5-1.el8_9.1.alma.1 |
| `webkit2gtk3-devel` | AlmaLinux:8 | All versions | 2.40.5-1.el8_9.1.alma.1 |
| `webkit2gtk3-jsc` | AlmaLinux:8 | All versions | 2.40.5-1.el8_9.1.alma.1 |
| `webkit2gtk3-jsc-devel` | AlmaLinux:8 | All versions | 2.40.5-1.el8_9.1.alma.1 |
| `webkit2gtk3` | AlmaLinux:9 | All versions | 2.40.5-1.el9_3.1 |
| `webkit2gtk3-devel` | AlmaLinux:9 | All versions | 2.40.5-1.el9_3.1 |
| `webkit2gtk3-jsc` | AlmaLinux:9 | All versions | 2.40.5-1.el9_3.1 |
| `webkit2gtk3-jsc-devel` | AlmaLinux:9 | All versions | 2.40.5-1.el9_3.1 |
| `webkit2gtk3` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.40.5-1.el8_9.1 |
| `webkit2gtk3-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.40.5-1.el8_9.1 |
| `webkit2gtk3-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.40.5-1.el8_9.1 |
| `webkit2gtk3-devel` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.40.5-1.el8_9.1 |
| `webkit2gtk3-devel-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.40.5-1.el8_9.1 |
| `webkit2gtk3-jsc` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.40.5-1.el8_9.1 |
| `webkit2gtk3-jsc-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.40.5-1.el8_9.1 |
| `webkit2gtk3-jsc-devel` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.40.5-1.el8_9.1 |
| `webkit2gtk3-jsc-devel-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.40.5-1.el8_9.1 |
| `webkit2gtk3` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.40.5-1.el9_3.1 |
| `webkit2gtk3-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.40.5-1.el9_3.1 |
| `webkit2gtk3-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.40.5-1.el9_3.1 |
| `webkit2gtk3-devel` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.40.5-1.el9_3.1 |
| `webkit2gtk3-devel-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.40.5-1.el9_3.1 |
| `webkit2gtk3-jsc` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.40.5-1.el9_3.1 |
| `webkit2gtk3-jsc-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.40.5-1.el9_3.1 |
| `webkit2gtk3-jsc-devel` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.40.5-1.el9_3.1 |
| `webkit2gtk3-jsc-devel-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.40.5-1.el9_3.1 |
| `webkit2gtk3` | Rocky Linux:8 | All versions | 0:2.40.5-1.el8_9.1 |

Products: Apple Ipados, Apple Iphone Os, Apple Macos, Apple Safari, Debian Debian Linux, Fedoraproject Fedora, Webkitgtk Webkitgtk\+.

## How do I fix CVE-2023-42917?

Upgrade java to a fixed version for your release line: 1.8.0 or 8.0.411. US federal agencies must fix it by 25 Dec 2023.

## Is CVE-2023-42917 being exploited?

Yes. Attackers have exploited CVE-2023-42917 in the wild since at least 4 Dec 2023.

## Other vulnerabilities in Apple Ipados

- [CVE-2025-43300](https://insights.sbomify.com/CVE-2025-43300/): Apple iOS, iPadOS, and macOS Out-of-Bounds Write (critical 10.0, exploited in the wild)
- [CVE-2025-24201](https://insights.sbomify.com/CVE-2025-24201/): Apple Multiple Products WebKit Out-of-Bounds Write (critical 10.0, exploited in the wild)
- [CVE-2025-24085](https://insights.sbomify.com/CVE-2025-24085/): Apple Multiple Products Use-After-Free (critical 10.0, exploited in the wild)
- [CVE-2025-31200](https://insights.sbomify.com/CVE-2025-31200/): Apple Multiple Products Memory Corruption (critical 9.8, exploited in the wild)
- [CVE-2025-31201](https://insights.sbomify.com/CVE-2025-31201/): Apple Multiple Products Arbitrary Read and Write (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42917 and fix it if it is affected.

What it is: CVE-2023-42917 is a high-severity memory corruption vulnerability in Apple Ipados, published on 30 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: Yes. Attackers have exploited CVE-2023-42917 in the wild since at least 4 Dec 2023.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.8.0, 8.0.411
- java-min (Bitnami): affected all versions; fixed in 1.8.0, 8.0.411
- jre (Bitnami): affected all versions; fixed in 1.8.0, 8.0.411

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42917/ (Markdown: https://insights.sbomify.com/CVE-2023-42917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42917
- OSV: https://osv.dev/vulnerability/CVE-2023-42917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42917/
Summaries are generated and may contain mistakes; the official description above is the record.
