# CVE-2023-4302: Missing permission checks in Fortify Plugin allow capturing credentials

> Attackers with read permissions can capture stored credentials by connecting to attacker-controlled URLs due to missing permission checks.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2023
- **Updated:** 1 Oct 2024
- **Also known as:** GHSA-4xmf-344q-m4cc

## What is CVE-2023-4302?

CVE-2023-4302 is a medium-severity missing authorization vulnerability in Jenkins Fortify Plugin, published on 21 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins Fortify Plugin 22.1.38 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-4302?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:fortify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:fortify` | Maven | All versions | 22.2.39 |
| `org.jenkins-ci.plugins:fortify` | Maven | All versions | 22.2.39 |

Products: Jenkins Fortify.

## How do I fix CVE-2023-4302?

Upgrade org.jenkins-ci.plugins:fortify to 22.2.39 or later.

## Is CVE-2023-4302 being exploited?

There is no known exploitation of CVE-2023-4302 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Fortify Plugin

- [CVE-2023-4303](https://insights.sbomify.com/CVE-2023-4303/): HTML injection vulnerability in Fortify Plugin (medium 4.3)
- [CVE-2022-25188](https://insights.sbomify.com/CVE-2022-25188/): Path traversal vulnerability in Jenkins Fortify Plugin (medium 4.3)
- [CVE-2020-2107](https://insights.sbomify.com/CVE-2020-2107/): Fortify Plugin stored credentials in plain text (medium 4.3)
- [CVE-2023-4301](https://insights.sbomify.com/CVE-2023-4301/): CSRF vulnerability in Fortify Plugin allow capturing credentials (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-4302 and fix it if it is affected.

What it is: CVE-2023-4302 is a medium-severity missing authorization vulnerability in Jenkins Fortify Plugin, published on 21 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-4302 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:fortify (Maven): affected all versions; fixed in 22.2.39
- org.jenkins-ci.plugins:fortify (Maven): affected all versions; fixed in 22.2.39

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-4302/ (Markdown: https://insights.sbomify.com/CVE-2023-4302/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-4302
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-4302
- OSV: https://osv.dev/vulnerability/CVE-2023-4302

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-4302/
Summaries are generated and may contain mistakes; the official description above is the record.
