{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:fortify. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-4303 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:fortify to 22.2.39 or later.","what":"CVE-2023-4303 is a medium-severity cross-site scripting vulnerability in Jenkins Fortify Plugin, published on 21 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-4303 and fix it if it is affected.\n\nWhat it is: CVE-2023-4303 is a medium-severity cross-site scripting vulnerability in Jenkins Fortify Plugin, published on 21 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-4303 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:fortify (Maven): affected all versions; fixed in 22.2.39\n- org.jenkins-ci.plugins:fortify (Maven): affected all versions; fixed in 22.2.39\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-4303/ (Markdown: https://insights.sbomify.com/CVE-2023-4303/index.md)","id":"CVE-2023-4303","markdown":"https://insights.sbomify.com/CVE-2023-4303/index.md","name":"CVE-2023-4303","record":{"aliases":["GHSA-223m-pgcq-f3xg"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Fortify Plugin","requires_auth":"none","summary":"An attacker can inject malicious HTML into Jenkins Fortify Plugin error messages, potentially leading to script execution or session hijacking.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"OpenText","cpe":[{"product":"fortify","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Fortify Plugin 22.1.38 and earlier does not escape the error message for a form validation method, resulting in an HTML injection vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HTML injection vulnerability in Fortify Plugin","id":"CVE-2023-4303","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Business Logic Errors in froxlor/froxlor","id":"CVE-2023-4304"},"packages":[{"ecosystem":"Maven","fixed":["22.2.39"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:fortify","purl":null,"source":"GHSA-223m-pgcq-f3xg"},{"ecosystem":"Maven","fixed":["22.2.39"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:fortify","purl":"pkg:maven/org.jenkins-ci.plugins/fortify","source":"GHSA-223m-pgcq-f3xg"}],"prev":{"headline":"Missing permission checks in Fortify Plugin allow capturing credentials","id":"CVE-2023-4302"},"products":["Jenkins Fortify Plugin"],"published":"2023-08-21","related":[{"cvss_score":4.3,"headline":"Path traversal vulnerability in Jenkins Fortify Plugin","id":"CVE-2022-25188","kev_date_added":null,"published":"2022-02-15"},{"cvss_score":4.3,"headline":"Fortify Plugin stored credentials in plain text","id":"CVE-2020-2107","kev_date_added":null,"published":"2020-01-29"},{"cvss_score":4.2,"headline":"CSRF vulnerability in Fortify Plugin allow capturing credentials","id":"CVE-2023-4301","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":4.2,"headline":"Missing permission checks in Fortify Plugin allow capturing credentials","id":"CVE-2023-4302","kev_date_added":null,"published":"2023-08-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-01","vendors":["Jenkins Project"]},"summary":"An attacker can inject malicious HTML into Jenkins Fortify Plugin error messages, potentially leading to script execution or session hijacking.","url":"https://insights.sbomify.com/CVE-2023-4303/"}