# CVE-2023-4316: Zod 3.22.2 - Regular expression Denial of Service

> An attacker can cause a denial of service by submitting specially crafted email strings to the Zod validation library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2023
- **Updated:** 3 Dec 2025
- **Also known as:** CLSA-2026-1782867616, GHSA-m95q-7qp3-xv42

## What is CVE-2023-4316?

CVE-2023-4316 is a high-severity denial of service vulnerability in Zod, published on 28 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Zod in versions 3.21.0 up to and including 3.22.3 allows an attacker to perform a denial of service while validating emails.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2023-4316?

2 open source packages ship an affected version, including zod. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zod` | npm | All versions | 3.22.3 |
| `zod` | npm | All versions | 3.22.3 |

Products: Zod Zod.

## How do I fix CVE-2023-4316?

Upgrade zod to 3.22.3 or later.

## Is CVE-2023-4316 being exploited?

There is no known exploitation of CVE-2023-4316 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-4316 and fix it if it is affected.

What it is: CVE-2023-4316 is a high-severity denial of service vulnerability in Zod, published on 28 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-4316 in the wild and no public exploit code.

Affected packages and fixed versions:
- zod (npm): affected all versions; fixed in 3.22.3
- zod (npm): affected all versions; fixed in 3.22.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-4316/ (Markdown: https://insights.sbomify.com/CVE-2023-4316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-4316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-4316
- OSV: https://osv.dev/vulnerability/CVE-2023-4316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-4316/
Summaries are generated and may contain mistakes; the official description above is the record.
