# CVE-2023-43364: Searchor CLI's Search vulnerable to Arbitrary Code using Eval

> Attackers can execute arbitrary code via CLI input in the Searchor library due to unsafe eval usage.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2023
- **Updated:** 9 Oct 2024
- **Also known as:** GHSA-66m2-493m-crh2, PYSEC-2023-262

## What is CVE-2023-43364?

CVE-2023-43364 is a critical code injection vulnerability in n/a, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

main.py in Searchor before 2.4.2 uses eval on CLI input, which may cause unexpected code execution.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-43364?

3 open source packages ship an affected version, including searchor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `searchor` | PyPI | All versions | 2.4.2 |
| `searchor` | PyPI | All versions | 2.4.2 |
| `searchor` | PyPI | All versions | 2.4.2 |

Products: Arjunsharda Searchor.

## How do I fix CVE-2023-43364?

Upgrade searchor to 2.4.2 or later.

## Is CVE-2023-43364 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-43364 exists.

Public exploit code:

- POC exploit via unsafe `eval()` usage in Searchor (< 2.4.2) (github_poc): https://github.com/Herick-Costa/CVE-2023-43364-Searchor-RCE-Exploit
- https://github.com/libertycityhacker/CVE-2023-43364-Exploit-CVE (github_poc): https://github.com/libertycityhacker/CVE-2023-43364-Exploit-CVE
- https://github.com/IamSaishi/CVE-2023-43364_Exploit (github_poc): https://github.com/IamSaishi/CVE-2023-43364_Exploit

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-43364 and fix it if it is affected.

What it is: CVE-2023-43364 is a critical code injection vulnerability in n/a, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-43364 exists.

Affected packages and fixed versions:
- searchor (PyPI): affected all versions; fixed in 2.4.2
- searchor (PyPI): affected all versions; fixed in 2.4.2
- searchor (PyPI): affected all versions; fixed in 2.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-43364/ (Markdown: https://insights.sbomify.com/CVE-2023-43364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-43364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-43364
- OSV: https://osv.dev/vulnerability/CVE-2023-43364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-43364/
Summaries are generated and may contain mistakes; the official description above is the record.
