# CVE-2023-43494: Jenkins does not exclude sensitive build variables from search

> Attackers with read permissions can extract sensitive build variables, such as passwords, from the build history widget via character-by-character testing.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Sep 2023
- **Updated:** 24 Sep 2024
- **Also known as:** BIT-jenkins-2023-43494, GHSA-279f-qwgh-h5mp

## What is CVE-2023-43494?

CVE-2023-43494 is a medium-severity vulnerability in Jenkins Jenkins, published on 20 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins 2.50 through 2.423 (both inclusive), LTS 2.60.1 through 2.414.1 (both inclusive) does not exclude sensitive build variables (e.g., password parameter values) from the search in the build history widget, allowing attackers with Item/Read permission to obtain values of sensitive variables used in builds by iteratively testing different characters until the correct sequence is discovered.

## Which versions are affected by CVE-2023-43494?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.415 | 2.424 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.415 | 2.424 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.50 | 2.414.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.50 | 2.414.2 |
| `jenkins` | Bitnami | From 2.50.0 | 2.424.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2023-43494?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.424 or 2.414.2.

## Is CVE-2023-43494 being exploited?

There is no known exploitation of CVE-2023-43494 in the wild and no public exploit code.

Public exploit code:

- Jenkins 2.50 through 2.423 (both inclusive), LTS 2.60.1 through 2.414.1 (both inclusive) File Read (github_poc): https://github.com/mqxmm/CVE-2023-43494

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-43494 and fix it if it is affected.

What it is: CVE-2023-43494 is a medium-severity vulnerability in Jenkins Jenkins, published on 20 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-43494 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.415; fixed in 2.424
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.415; fixed in 2.424
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.50; fixed in 2.414.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.50; fixed in 2.414.2
- jenkins (Bitnami): affected from 2.50.0; fixed in 2.424.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-43494/ (Markdown: https://insights.sbomify.com/CVE-2023-43494/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-43494
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-43494
- OSV: https://osv.dev/vulnerability/CVE-2023-43494

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-43494/
Summaries are generated and may contain mistakes; the official description above is the record.
