# CVE-2023-43496: Jenkins temporary plugin file created with insecure permissions

> Attackers with local access can replace temporary plugin files during installation, leading to arbitrary code execution on the Jenkins server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Sep 2023
- **Updated:** 2 May 2025
- **Also known as:** BIT-jenkins-2023-43496, GHSA-55wp-3pq4-w8p9

## What is CVE-2023-43496?

CVE-2023-43496 is a high-severity vulnerability in Jenkins Jenkins, published on 20 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins 2.423 and earlier, LTS 2.414.1 and earlier creates a temporary file in the system temporary directory with the default permissions for newly created files when installing a plugin from a URL, potentially allowing attackers with access to the system temporary directory to replace the file before it is installed in Jenkins, potentially resulting in arbitrary code execution.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2023-43496?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.415 | 2.424 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.415 | 2.424 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.50 | 2.414.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.50 | 2.414.2 |
| `jenkins` | Bitnami | All versions | 2.424.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2023-43496?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.424 or 2.414.2.

## Is CVE-2023-43496 being exploited?

There is no known exploitation of CVE-2023-43496 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-43496 and fix it if it is affected.

What it is: CVE-2023-43496 is a high-severity vulnerability in Jenkins Jenkins, published on 20 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-43496 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.415; fixed in 2.424
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.415; fixed in 2.424
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.50; fixed in 2.414.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.50; fixed in 2.414.2
- jenkins (Bitnami): affected all versions; fixed in 2.424.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-43496/ (Markdown: https://insights.sbomify.com/CVE-2023-43496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-43496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-43496
- OSV: https://osv.dev/vulnerability/CVE-2023-43496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-43496/
Summaries are generated and may contain mistakes; the official description above is the record.
