CVE-2023-43641 libcue vulnerable to out-of-bounds array access
Attackers can achieve code execution by tricking users into downloading malicious CUE sheets that trigger an out-of-bounds array access in libcue during automatic scanning.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-43641?
CVE-2023-43641 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 9 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
libcue provides an API for parsing and extracting data from CUE sheets. Versions 2.2.1 and prior are vulnerable to out-of-bounds array access. A user of the GNOME desktop environment can be exploited by downloading a cue sheet from a malicious webpage. Because the file is saved to `~/Downloads`, it is then automatically scanned by tracker-miners. And because it has a .cue filename extension, tracker-miners use libcue to parse the file. The file exploits the vulnerability in libcue to gain code execution. This issue is patched in version 2.3.0.
Weakness: CWE-787
Which versions are affected by CVE-2023-43641?
It affects 3 products.
Linux distribution packages (12)
libcue SUSE:Enterprise Storage 7.1 | All versions | 2.1.0-150000.3.3.1 |
libcue SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 2.1.0-150000.3.3.1 |
libcue SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 2.1.0-150000.3.3.1 |
libcue SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 2.1.0-150000.3.3.1 |
libcue SUSE:Linux Enterprise Module for Desktop Applications 15 SP4 | All versions | 2.1.0-150000.3.3.1 |
libcue SUSE:Linux Enterprise Module for Desktop Applications 15 SP5 | All versions | 2.1.0-150000.3.3.1 |
libcue SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 2.1.0-150000.3.3.1 |
libcue SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 2.1.0-150000.3.3.1 |
libcue SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 2.1.0-150000.3.3.1 |
libcue SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 2.1.0-150000.3.3.1 |
libcue SUSE:Linux Enterprise Workstation Extension 15 SP4 | All versions | 2.1.0-150000.3.3.1 |
libcue SUSE:Linux Enterprise Workstation Extension 15 SP5 | All versions | 2.1.0-150000.3.3.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Lipnitsk Libcue.
How do I fix CVE-2023-43641?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2023-43641 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-43641 exists.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2023-43641, DLA-3615-1, DSA-5524-1, GHSA-5982-x7hv-r9cj, MGASA-2023-0300, OESA-2023-1743 and 7 more.