{"answers":{"affected":"2 open source packages ship an affected version, including org.xerial.snappy:snappy-java. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-43642 exists.","fix":"Upgrade org.xerial.snappy:snappy-java to 1.1.10.4 or later.","what":"CVE-2023-43642 is a high-severity denial of service vulnerability in xerial snappy-java, published on 25 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-43642 and fix it if it is affected.\n\nWhat it is: CVE-2023-43642 is a high-severity denial of service vulnerability in xerial snappy-java, published on 25 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-43642 exists.\n\nAffected packages and fixed versions:\n- org.xerial.snappy:snappy-java (Maven): affected all versions; fixed in 1.1.10.4\n- org.xerial.snappy:snappy-java (Maven): affected all versions; fixed in 1.1.10.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-43642/ (Markdown: https://insights.sbomify.com/CVE-2023-43642/index.md)","id":"CVE-2023-43642","markdown":"https://insights.sbomify.com/CVE-2023-43642/index.md","name":"CVE-2023-43642","record":{"aliases":["CLEANSTART-2026-HS17882","CLEANSTART-2026-TL41990","CLSA-2026-1777250302","DEBIAN-CVE-2023-43642","ECHO-36e1-902e-4338","GHSA-55g7-9cwv-5qfv","OESA-2023-1700","ROOT-APP-MAVEN-CVE-2023-43642","UBUNTU-CVE-2023-43642"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java compression library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using snappy-java by providing compressed data with excessively large chunk sizes.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"snappy-java","vendor":"xerial"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"snappy-java is a Java port of the snappy, a fast C++ compresser/decompresser developed by Google. The SnappyInputStream was found to be vulnerable to Denial of Service (DoS) attacks when decompressing data with a too large chunk size. Due to missing upper bound check on chunk length, an unrecoverable fatal error can occur. All versions of snappy-java including the latest released version 1.1.10.3 are vulnerable to this issue. A fix has been introduced in commit `9f8c3cf74` which will be included in the 1.1.10.4 release. Users are advised to upgrade. Users unable to upgrade should only accept compressed data from trusted sources.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Missing upper bound check on chunk length in snappy-java","id":"CVE-2023-43642","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"mXSS in AntiSamy","id":"CVE-2023-43643"},"packages":[{"ecosystem":"Maven","fixed":["1.1.10.4"],"introduced":["0"],"last_affected":[],"package":"org.xerial.snappy:snappy-java","purl":null,"source":"GHSA-55g7-9cwv-5qfv"},{"ecosystem":"Maven","fixed":["1.1.10.4"],"introduced":["0"],"last_affected":[],"package":"org.xerial.snappy:snappy-java","purl":"pkg:maven/org.xerial.snappy/snappy-java","source":"GHSA-55g7-9cwv-5qfv"}],"prev":{"headline":"libcue vulnerable to out-of-bounds array access","id":"CVE-2023-43641"},"products":["snappy-java"],"published":"2023-09-25","related":[{"cvss_score":7.5,"headline":"snappy-java's unchecked chunk length leads to DoS","id":"CVE-2023-34455","kev_date_added":null,"published":"2023-06-15"},{"cvss_score":5.9,"headline":"snappy-java's Integer Overflow vulnerability in shuffle leads to DoS","id":"CVE-2023-34453","kev_date_added":null,"published":"2023-06-15"},{"cvss_score":5.9,"headline":"snappy-java's Integer Overflow vulnerability in compress leads to DoS","id":"CVE-2023-34454","kev_date_added":null,"published":"2023-06-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-24","vendors":["xerial"]},"summary":"Attackers can cause denial of service in applications using snappy-java by providing compressed data with excessively large chunk sizes.","url":"https://insights.sbomify.com/CVE-2023-43642/"}