{"answers":{"affected":"2 open source packages ship an affected version, including org.owasp.antisamy:antisamy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-43643 in the wild and no public exploit code.","fix":"Upgrade org.owasp.antisamy:antisamy to 1.7.4 or later.","what":"CVE-2023-43643 is a medium-severity vulnerability in nahsra antisamy, published on 9 Oct 2023."},"fix_prompt":"Check this codebase for CVE-2023-43643 and fix it if it is affected.\n\nWhat it is: CVE-2023-43643 is a medium-severity vulnerability in nahsra antisamy, published on 9 Oct 2023. \nExploitation: There is no known exploitation of CVE-2023-43643 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.7.4\n- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.7.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-43643/ (Markdown: https://insights.sbomify.com/CVE-2023-43643/index.md)","id":"CVE-2023-43643","markdown":"https://insights.sbomify.com/CVE-2023-43643/index.md","name":"CVE-2023-43643","record":{"aliases":["DEBIAN-CVE-2023-43643","GHSA-pcf2-gh6g-h5r2","UBUNTU-CVE-2023-43643"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"antisamy","vendor":"antisamy_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to version 1.7.4, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file and also allow for certain tags at the same time. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. This issue has been patched in AntiSamy 1.7.4 and later.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"mXSS in AntiSamy","id":"CVE-2023-43643","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":null,"year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Improper authentication in the SOCKS5 inbound in sing-box","id":"CVE-2023-43644"},"packages":[{"ecosystem":"Maven","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"org.owasp.antisamy:antisamy","purl":null,"source":"GHSA-pcf2-gh6g-h5r2"},{"ecosystem":"Maven","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"org.owasp.antisamy:antisamy","purl":"pkg:maven/org.owasp.antisamy/antisamy","source":"GHSA-pcf2-gh6g-h5r2"}],"prev":{"headline":"Missing upper bound check on chunk length in snappy-java","id":"CVE-2023-43642"},"products":["antisamy"],"published":"2023-10-09","related":[{"cvss_score":7.5,"headline":"Denial of service in HtmlUnit-Neko","id":"CVE-2022-28366","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"AntiSamy malicious input can provoke XSS when preserving comments","id":"CVE-2024-23635","kev_date_added":null,"published":"2024-02-02"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2022-28367","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2022-29577","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2021-35043","kev_date_added":null,"published":"2021-07-19"},{"cvss_score":6.1,"headline":"OWASP AntiSamy Cross-site Scripting vulnerability","id":"CVE-2017-14735","kev_date_added":null,"published":"2017-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-19","vendors":["nahsra"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2023-43643/"}