# CVE-2023-43643: mXSS in AntiSamy


- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Oct 2023
- **Updated:** 19 Sep 2024
- **Also known as:** DEBIAN-CVE-2023-43643, GHSA-pcf2-gh6g-h5r2, UBUNTU-CVE-2023-43643

## What is CVE-2023-43643?

CVE-2023-43643 is a medium-severity vulnerability in nahsra antisamy, published on 9 Oct 2023. 

### Official description

AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to version 1.7.4, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file and also allow for certain tags at the same time. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. This issue has been patched in AntiSamy 1.7.4 and later.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-43643?

2 open source packages ship an affected version, including org.owasp.antisamy:antisamy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.owasp.antisamy:antisamy` | Maven | All versions | 1.7.4 |
| `org.owasp.antisamy:antisamy` | Maven | All versions | 1.7.4 |

Products: Antisamy Project Antisamy.

## How do I fix CVE-2023-43643?

Upgrade org.owasp.antisamy:antisamy to 1.7.4 or later.

## Is CVE-2023-43643 being exploited?

There is no known exploitation of CVE-2023-43643 in the wild and no public exploit code.

## Other vulnerabilities in nahsra antisamy

- [CVE-2022-28366](https://insights.sbomify.com/CVE-2022-28366/): Denial of service in HtmlUnit-Neko (high 7.5)
- [CVE-2024-23635](https://insights.sbomify.com/CVE-2024-23635/): AntiSamy malicious input can provoke XSS when preserving comments (medium 6.1)
- [CVE-2022-28367](https://insights.sbomify.com/CVE-2022-28367/): Cross-site Scripting in OWASP AntiSamy (medium 6.1)
- [CVE-2022-29577](https://insights.sbomify.com/CVE-2022-29577/): Cross-site Scripting in OWASP AntiSamy (medium 6.1)
- [CVE-2021-35043](https://insights.sbomify.com/CVE-2021-35043/): Cross-site Scripting in OWASP AntiSamy (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-43643 and fix it if it is affected.

What it is: CVE-2023-43643 is a medium-severity vulnerability in nahsra antisamy, published on 9 Oct 2023. 
Exploitation: There is no known exploitation of CVE-2023-43643 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.7.4
- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-43643/ (Markdown: https://insights.sbomify.com/CVE-2023-43643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-43643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-43643
- OSV: https://osv.dev/vulnerability/CVE-2023-43643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-43643/
Summaries are generated and may contain mistakes; the official description above is the record.
