# CVE-2023-43659: Cross-site Scripting via email preview when CSP disabled in Discourse

> Attackers can execute arbitrary scripts via email preview in Discourse when Content Security Policy is disabled, potentially compromising user accounts.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Oct 2023
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-discourse-2023-43659, GHSA-g4qg-5q2h-m8ph

## What is CVE-2023-43659?

CVE-2023-43659 is a high-severity cross-site scripting vulnerability in Discourse Discourse, published on 16 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Discourse is an open source platform for community discussion. Improper escaping of user input allowed for Cross-site Scripting attacks via the digest email preview UI. This issue only affects sites with CSP disabled. This issue has been patched in the 3.1.1 stable release as well as the 3.2.0.beta1 release. Users are advised to upgrade. Users unable to upgrade should ensure CSP is enabled on the forum.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-43659?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions to 3.1.1 | None |

Products: Discourse Discourse.

## How do I fix CVE-2023-43659?

No fix has been published for CVE-2023-43659 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-43659 being exploited?

There is no known exploitation of CVE-2023-43659 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-43659 and fix it if it is affected.

What it is: CVE-2023-43659 is a high-severity cross-site scripting vulnerability in Discourse Discourse, published on 16 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-43659 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions up to 3.1.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-43659/ (Markdown: https://insights.sbomify.com/CVE-2023-43659/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-43659
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-43659
- OSV: https://osv.dev/vulnerability/CVE-2023-43659

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-43659/
Summaries are generated and may contain mistakes; the official description above is the record.
