# CVE-2023-43664: Employee without any access rights can list all installed modules in Prestashop

> An employee without access rights can list all installed modules in PrestaShop due to missing authorization checks in the back office.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2023
- **Updated:** 20 Sep 2024
- **Also known as:** GHSA-gvrg-62jp-rf7j

## What is CVE-2023-43664?

CVE-2023-43664 is a medium-severity missing authorization vulnerability in Prestashop Prestashop, published on 28 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PrestaShop is an Open Source e-commerce web application. In the Prestashop Back office interface, an employee can list all modules without any access rights: method `ajaxProcessGetPossibleHookingListForModule` doesn't check access rights. This issue has been addressed in commit `15bd281c` which is included in version 8.1.2. Users are advised to upgrade. There are no known workaround for this issue.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-43664?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 8.1.2 |
| `prestashop/prestashop` | Packagist | All versions | 8.1.2 |

Products: Prestashop Prestashop.

## How do I fix CVE-2023-43664?

Upgrade prestashop/prestashop to 8.1.2 or later.

## Is CVE-2023-43664 being exploited?

There is no known exploitation of CVE-2023-43664 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-43664 and fix it if it is affected.

What it is: CVE-2023-43664 is a medium-severity missing authorization vulnerability in Prestashop Prestashop, published on 28 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-43664 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.1.2
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-43664/ (Markdown: https://insights.sbomify.com/CVE-2023-43664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-43664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-43664
- OSV: https://osv.dev/vulnerability/CVE-2023-43664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-43664/
Summaries are generated and may contain mistakes; the official description above is the record.
