CVE-2023-43665 Django Denial-of-service in django.utils.text.Truncator
Attackers can cause denial of service in Django applications by sending malformed HTML to specific text truncation utilities.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-43665?
CVE-2023-43665 is a high-severity denial of service vulnerability in Djangoproject Django, published on 3 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Django 3.2 before 3.2.22, 4.1 before 4.1.12, and 4.2 before 4.2.6, the django.utils.text.Truncator chars() and words() methods (when used with html=True) are subject to a potential DoS (denial of service) attack via certain inputs with very long, potentially malformed HTML text. The chars() and words() methods are used to implement the truncatechars_html and truncatewords_html template filters, which are thus also vulnerable. NOTE: this issue exists because of an incomplete fix for CVE-2019-14232.
Weakness: CWE-1284
Which versions are affected by CVE-2023-43665?
8 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 3.2.0 | 3.2.22, 4.1.12, 4.2.6 |
django PyPI | From 3.2 | 3.2.22, 4.1.12, 4.2.6 |
django PyPI | From 3.2a1 | 3.2.22 |
django PyPI | From 4.1a1 | 4.1.12 |
django PyPI | From 4.2a1 | 4.2.6 |
Django PyPI | From 3.2a1 | 3.2.22 |
2 more packages
Django PyPI | From 4.1a1 | 4.1.12 |
Django PyPI | From 4.2a1 | 4.2.6 |
Linux distribution packages (14)
python-Django SUSE:HPE Helion OpenStack 8 | All versions | 1.11.29-3.54.1 |
python-Django SUSE:OpenStack Cloud 8 | All versions | 1.11.29-3.54.1 |
python-Django1 SUSE:OpenStack Cloud 9 | All versions | 1.11.29-3.53.1 |
python-Django SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.11.29-3.54.1 |
python-Django1 SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.11.29-3.53.1 |
python-Django SUSE:Package Hub 15 SP4 | All versions | 2.2.28-bp154.2.15.1 |
python-Django1 SUSE:Package Hub 15 SP4 | All versions | 1.11.29-bp154.2.9.1 |
python-Django SUSE:Package Hub 15 SP5 | All versions | 2.2.28-bp155.7.6.1 |
python-Django1 SUSE:Package Hub 15 SP5 | All versions | 1.11.29-bp155.4.6.1 |
python-Django openSUSE:Leap 15.4 | All versions | 2.2.28-bp154.2.15.1 |
python-Django1 openSUSE:Leap 15.4 | All versions | 1.11.29-bp154.2.9.1 |
python-Django openSUSE:Leap 15.5 | All versions | 2.2.28-bp155.7.6.1 |
python-Django1 openSUSE:Leap 15.5 | All versions | 1.11.29-bp155.4.6.1 |
python-Django openSUSE:Tumbleweed | All versions | 4.2.6-1.1 |
Products include Djangoproject Django, Fedoraproject Fedora.
How do I fix CVE-2023-43665?
Upgrade django to a fixed version for your release line: 3.2.22, 4.1.12 or 4.2.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-43665 being exploited?
There is no known exploitation of CVE-2023-43665 in the wild and no public exploit code.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as BIT-django-2023-43665, CLSA-2026-1784164007, DEBIAN-CVE-2023-43665, GHSA-h8gc-pgj2-vjm3, OESA-2023-1722, PYSEC-2023-226 and 9 more.