# CVE-2023-43665: Django Denial-of-service in django.utils.text.Truncator

> Attackers can cause denial of service in Django applications by sending malformed HTML to specific text truncation utilities.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Nov 2023
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-django-2023-43665, CLSA-2026-1784164007, DEBIAN-CVE-2023-43665, GHSA-h8gc-pgj2-vjm3, OESA-2023-1722, PYSEC-2023-226, SUSE-SU-2023:4232-1, SUSE-SU-2023:4426-1, UBUNTU-CVE-2023-43665, USN-6414-1, openSUSE-SU-2023:0309-1, openSUSE-SU-2023:0310-1, openSUSE-SU-2023:0389-1, openSUSE-SU-2023:0390-1, openSUSE-SU-2024:13334-1

## What is CVE-2023-43665?

CVE-2023-43665 is a high-severity denial of service vulnerability in Djangoproject Django, published on 3 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Django 3.2 before 3.2.22, 4.1 before 4.1.12, and 4.2 before 4.2.6, the django.utils.text.Truncator chars() and words() methods (when used with html=True) are subject to a potential DoS (denial of service) attack via certain inputs with very long, potentially malformed HTML text. The chars() and words() methods are used to implement the truncatechars_html and truncatewords_html template filters, which are thus also vulnerable. NOTE: this issue exists because of an incomplete fix for CVE-2019-14232.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2023-43665?

8 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 3.2.0 | 3.2.22, 4.1.12, 4.2.6 |
| `django` | PyPI | From 3.2 | 3.2.22, 4.1.12, 4.2.6 |
| `django` | PyPI | From 3.2a1 | 3.2.22 |
| `django` | PyPI | From 4.1a1 | 4.1.12 |
| `django` | PyPI | From 4.2a1 | 4.2.6 |
| `Django` | PyPI | From 3.2a1 | 3.2.22 |
| `Django` | PyPI | From 4.1a1 | 4.1.12 |
| `Django` | PyPI | From 4.2a1 | 4.2.6 |
| `python-Django` | SUSE:HPE Helion OpenStack 8 | All versions | 1.11.29-3.54.1 |
| `python-Django` | SUSE:OpenStack Cloud 8 | All versions | 1.11.29-3.54.1 |
| `python-Django1` | SUSE:OpenStack Cloud 9 | All versions | 1.11.29-3.53.1 |
| `python-Django` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.11.29-3.54.1 |
| `python-Django1` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.11.29-3.53.1 |
| `python-Django` | SUSE:Package Hub 15 SP4 | All versions | 2.2.28-bp154.2.15.1 |
| `python-Django1` | SUSE:Package Hub 15 SP4 | All versions | 1.11.29-bp154.2.9.1 |
| `python-Django` | SUSE:Package Hub 15 SP5 | All versions | 2.2.28-bp155.7.6.1 |
| `python-Django1` | SUSE:Package Hub 15 SP5 | All versions | 1.11.29-bp155.4.6.1 |
| `python-Django` | openSUSE:Leap 15.4 | All versions | 2.2.28-bp154.2.15.1 |
| `python-Django1` | openSUSE:Leap 15.4 | All versions | 1.11.29-bp154.2.9.1 |
| `python-Django` | openSUSE:Leap 15.5 | All versions | 2.2.28-bp155.7.6.1 |
| `python-Django1` | openSUSE:Leap 15.5 | All versions | 1.11.29-bp155.4.6.1 |
| `python-Django` | openSUSE:Tumbleweed | All versions | 4.2.6-1.1 |

Products: Djangoproject Django, Fedoraproject Fedora.

## How do I fix CVE-2023-43665?

Upgrade django to a fixed version for your release line: 3.2.22, 4.1.12 or 4.2.6.

## Is CVE-2023-43665 being exploited?

There is no known exploitation of CVE-2023-43665 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-43665 and fix it if it is affected.

What it is: CVE-2023-43665 is a high-severity denial of service vulnerability in Djangoproject Django, published on 3 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-43665 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 3.2.0; fixed in 3.2.22, 4.1.12, 4.2.6
- django (PyPI): affected from 3.2; fixed in 3.2.22, 4.1.12, 4.2.6
- django (PyPI): affected from 3.2a1; fixed in 3.2.22
- django (PyPI): affected from 4.1a1; fixed in 4.1.12
- django (PyPI): affected from 4.2a1; fixed in 4.2.6
- Django (PyPI): affected from 3.2a1; fixed in 3.2.22
- Django (PyPI): affected from 4.1a1; fixed in 4.1.12
- Django (PyPI): affected from 4.2a1; fixed in 4.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-43665/ (Markdown: https://insights.sbomify.com/CVE-2023-43665/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-43665
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-43665
- OSV: https://osv.dev/vulnerability/CVE-2023-43665

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-43665/
Summaries are generated and may contain mistakes; the official description above is the record.
