# CVE-2023-43701: Apache Superset: Stored XSS on API endpoint

> An authenticated attacker can store malicious code in Chart metadata, leading to script execution when a user accesses a specific deprecated API endpoint.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-superset-2023-43701, GHSA-wq8q-99p5-xfrw, PYSEC-2026-1190

## What is CVE-2023-43701?

CVE-2023-43701 is a medium-severity cross-site scripting vulnerability in Apache Superset, published on 27 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache Superset versions prior to 2.1.2. 
Users are recommended to upgrade to version 2.1.2, which fixes this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-43701?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 2.1.2 |
| `apache-superset` | PyPI | All versions | 2.1.2 |
| `apache-superset` | PyPI | All versions | 2.1.2 |
| `superset` | Bitnami | All versions | 2.1.2 |

Products: Apache Superset.

## How do I fix CVE-2023-43701?

Upgrade apache-superset to 2.1.2 or later.

## Is CVE-2023-43701 being exploited?

There is no known exploitation of CVE-2023-43701 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-43701 and fix it if it is affected.

What it is: CVE-2023-43701 is a medium-severity cross-site scripting vulnerability in Apache Superset, published on 27 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-43701 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 2.1.2
- apache-superset (PyPI): affected all versions; fixed in 2.1.2
- apache-superset (PyPI): affected all versions; fixed in 2.1.2
- superset (Bitnami): affected all versions; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-43701/ (Markdown: https://insights.sbomify.com/CVE-2023-43701/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-43701
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-43701
- OSV: https://osv.dev/vulnerability/CVE-2023-43701

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-43701/
Summaries are generated and may contain mistakes; the official description above is the record.
