CVE-2023-43770 Roundcube Webmail Persistent Cross-Site Scripting (XSS)
Attackers can execute arbitrary scripts in victim browsers via crafted links in plain text emails, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Since 12 Feb 2024
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-43770?
CVE-2023-43770 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 22 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Roundcube before 1.4.14, 1.5.x before 1.5.4, and 1.6.x before 1.6.3 allows XSS via text/plain e-mail messages with crafted links because of program/lib/Roundcube/rcube_string_replacer.php behavior.
Weakness: CWE-79
Which versions are affected by CVE-2023-43770?
1 open source package ship an affected version, including roundcube. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
roundcube Bitnami | All versions | 1.4.14, 1.5.4, 1.6.3 |
Products include Debian Debian Linux, Roundcube Webmail.
How do I fix CVE-2023-43770?
Upgrade roundcube to a fixed version for your release line: 1.4.14, 1.5.4 or 1.6.3. US federal agencies must fix it by 4 Mar 2024.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-43770 being exploited?
Yes. Attackers have exploited CVE-2023-43770 in the wild since at least 12 Feb 2024.
Public exploit code: 3 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-roundcube-2023-43770, DEBIAN-CVE-2023-43770, DLA-3577-1, GHSA-g3fv-4f2h-xwv4, UBUNTU-CVE-2023-43770, USN-6654-1.