{"answers":{"affected":"1 open source package ship an affected version, including roundcube. It affects 2 products.","exploited":"Yes. Attackers have exploited CVE-2023-43770 in the wild since at least 12 Feb 2024.","fix":"Upgrade roundcube to a fixed version for your release line: 1.4.14, 1.5.4 or 1.6.3. US federal agencies must fix it by 4 Mar 2024.","what":"CVE-2023-43770 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 22 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-43770 and fix it if it is affected.\n\nWhat it is: CVE-2023-43770 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 22 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: Yes. Attackers have exploited CVE-2023-43770 in the wild since at least 12 Feb 2024.\n\nAffected packages and fixed versions:\n- roundcube (Bitnami): affected all versions; fixed in 1.4.14, 1.5.4, 1.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-43770/ (Markdown: https://insights.sbomify.com/CVE-2023-43770/index.md)","id":"CVE-2023-43770","markdown":"https://insights.sbomify.com/CVE-2023-43770/index.md","name":"CVE-2023-43770","record":{"aliases":["BIT-roundcube-2023-43770","DEBIAN-CVE-2023-43770","DLA-3577-1","GHSA-g3fv-4f2h-xwv4","UBUNTU-CVE-2023-43770","USN-6654-1"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Roundcube webmail","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in victim browsers via crafted links in plain text emails, potentially leading to session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"webmail","vendor":"roundcube"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Roundcube before 1.4.14, 1.5.x before 1.5.4, and 1.6.x before 1.6.3 allows XSS via text/plain e-mail messages with crafted links because of program/lib/Roundcube/rcube_string_replacer.php behavior.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2023-09-27","github_poc":3,"max_poc_stars":35,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-09-27T17:08:23Z","kind":"github_poc","ref":"https://github.com/s3cb0y/CVE-2023-43770-POC","stars":35,"title":"A Proof-Of-Concept for the CVE-2023-43770 vulnerability. "},{"date":"2023-09-28T13:43:25Z","kind":"github_poc","ref":"https://github.com/knight0x07/CVE-2023-43770-PoC","stars":3,"title":"PoC for Stored XSS (CVE-2023-43770) Vulnerability"},{"date":"2025-04-20T07:30:38Z","kind":"github_poc","ref":"https://github.com/skyllpro/CVE-2021-44026-PoC","stars":0,"title":"Bug Chain XSS (CVE-2020-35730 and CVE-2023-43770) to SQLi (CVE-2021-44026)"}],"tier":"exploited"},"has_fix":true,"headline":"Roundcube Webmail Persistent Cross-Site Scripting (XSS)","id":"CVE-2023-43770","indexable":true,"kev":{"dateAdded":"2024-02-12","dueDate":"2024-03-04","knownRansomwareCampaignUse":"Unknown","product":"Webmail","requiredAction":"Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.","vendorProject":"Roundcube","vulnerabilityName":"Roundcube Webmail Persistent Cross-Site Scripting (XSS) Vulnerability"},"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","roundcube:webmail"],"type":"xss","year":"2023"},"n_packages":1,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2023-43771"},"packages":[{"ecosystem":"Bitnami","fixed":["1.4.14","1.5.4","1.6.3"],"introduced":["0","1.5.0","1.6.0"],"last_affected":[],"package":"roundcube","purl":"pkg:bitnami/roundcube","source":"BIT-roundcube-2023-43770"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2023-43769"},"products":["n/a"],"published":"2023-09-22","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"active","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-21","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts in victim browsers via crafted links in plain text emails, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2023-43770/"}