# CVE-2023-43770: Roundcube Webmail Persistent Cross-Site Scripting (XSS)

> Attackers can execute arbitrary scripts in victim browsers via crafted links in plain text emails, potentially leading to session hijacking or data theft.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Yes, since 12 Feb 2024 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Sep 2023
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-roundcube-2023-43770, DEBIAN-CVE-2023-43770, DLA-3577-1, GHSA-g3fv-4f2h-xwv4, UBUNTU-CVE-2023-43770, USN-6654-1

## What is CVE-2023-43770?

CVE-2023-43770 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 22 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Roundcube before 1.4.14, 1.5.x before 1.5.4, and 1.6.x before 1.6.3 allows XSS via text/plain e-mail messages with crafted links because of program/lib/Roundcube/rcube_string_replacer.php behavior.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-43770?

1 open source package ship an affected version, including roundcube. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `roundcube` | Bitnami | All versions | 1.4.14, 1.5.4, 1.6.3 |

Products: Debian Debian Linux, Roundcube Webmail.

## How do I fix CVE-2023-43770?

Upgrade roundcube to a fixed version for your release line: 1.4.14, 1.5.4 or 1.6.3. US federal agencies must fix it by 4 Mar 2024.

## Is CVE-2023-43770 being exploited?

Yes. Attackers have exploited CVE-2023-43770 in the wild since at least 12 Feb 2024.

Public exploit code:

- A Proof-Of-Concept for the CVE-2023-43770 vulnerability.  (github_poc): https://github.com/s3cb0y/CVE-2023-43770-POC
- PoC for Stored XSS (CVE-2023-43770) Vulnerability (github_poc): https://github.com/knight0x07/CVE-2023-43770-PoC
- Bug Chain XSS (CVE-2020-35730 and CVE-2023-43770) to SQLi (CVE-2021-44026) (github_poc): https://github.com/skyllpro/CVE-2021-44026-PoC

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-43770 and fix it if it is affected.

What it is: CVE-2023-43770 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 22 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: Yes. Attackers have exploited CVE-2023-43770 in the wild since at least 12 Feb 2024.

Affected packages and fixed versions:
- roundcube (Bitnami): affected all versions; fixed in 1.4.14, 1.5.4, 1.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-43770/ (Markdown: https://insights.sbomify.com/CVE-2023-43770/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-43770
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-43770
- OSV: https://osv.dev/vulnerability/CVE-2023-43770

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-43770/
Summaries are generated and may contain mistakes; the official description above is the record.
