CVE-2023-4378 Insertion of Sensitive Information Into Sent Data in GitLab
A malicious Maintainer can leak the Sentry token by modifying the configured URL in error tracking settings, exposing sensitive credentials.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-4378?
CVE-2023-4378 is a medium-severity vulnerability in Gitlab Gitlab, published on 1 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 11.8 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1. A malicious Maintainer can, under specific circumstances, leak the sentry token by changing the configured URL in the Sentry error tracking settings page. This was as a result of an incomplete fix for CVE-2022-4365.
Weakness: CWE-201
Which versions are affected by CVE-2023-4378?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.8.0 | 16.1.5, 16.2.5, 16.3.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-4378?
Upgrade gitlab to a fixed version for your release line: 16.1.5, 16.2.5 or 16.3.1.
Is CVE-2023-4378 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4378 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-4378, GHSA-mp7g-3r25-fq9v, UBUNTU-CVE-2023-4378.