CVE-2023-4379 Incorrect Authorization in GitLab
Attackers can bypass code owner approval requirements in GitLab EE by updating the target branch of a merge request.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-4379?
CVE-2023-4379 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 9 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
An issue has been discovered in GitLab EE affecting all versions starting from 15.3 prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1. Code owner approval was not removed from merge requests when the target branch was updated.
Weakness: CWE-863
Which versions are affected by CVE-2023-4379?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.3.0 | 16.2.8, 16.3.5, 16.4.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-4379?
Upgrade gitlab to a fixed version for your release line: 16.2.8, 16.3.5 or 16.4.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-4379 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4379 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-4379, GHSA-qrp8-hgrf-wv83.