CVE-2023-43796 Synapse vulnerable to leak of remote user device information
Attackers can enumerate remote users known to a Synapse homeserver by querying cached device information, exposing user metadata.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-43796?
CVE-2023-43796 is a medium-severity vulnerability in Fedoraproject Fedora, published on 31 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Synapse is an open-source Matrix homeserver Prior to versions 1.95.1 and 1.96.0rc1, cached device information of remote users can be queried from Synapse. This can be used to enumerate the remote users known to a homeserver. System administrators are encouraged to upgrade to Synapse 1.95.1 or 1.96.0rc1 to receive a patch. As a workaround, the `federation_domain_whitelist` can be used to limit federation traffic with a homeserver.
Weakness: CWE-200
Which versions are affected by CVE-2023-43796?
3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
matrix-synapse PyPI | All versions | 1.95.1 |
matrix-synapse PyPI | All versions | 1.95.1 |
matrix-synapse PyPI | All versions | 1.95.1 |
Linux distribution packages (1)
matrix-synapse openSUSE:Tumbleweed | All versions | 1.95.1-1.1 |
Products include Fedoraproject Fedora, Matrix Synapse.
How do I fix CVE-2023-43796?
Upgrade matrix-synapse to 1.95.1 or later.
Is CVE-2023-43796 being exploited?
There is no known exploitation of CVE-2023-43796 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as GHSA-mp92-3jfm-3575, PYSEC-2023-230, UBUNTU-CVE-2023-43796, openSUSE-SU-2024:13392-1.