# CVE-2023-43809: Soft Serve Public Key Authentication Bypass Vulnerability when Keyboard-Interactive SSH Authentication is Enabled

> Attackers can bypass public key authentication in Soft Serve Git server when keyboard-interactive SSH is enabled, gaining unauthorized access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2023
- **Updated:** 20 Sep 2024
- **Also known as:** GHSA-mc97-99j4-vm2v, GO-2023-2097

## What is CVE-2023-43809?

CVE-2023-43809 is a high-severity authentication bypass vulnerability in charmbracelet soft-serve, published on 4 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Soft Serve is a self-hostable Git server for the command line. Prior to version 0.6.2, a security vulnerability in Soft Serve could allow an unauthenticated, remote attacker to bypass public key authentication when keyboard-interactive SSH authentication is active, through the `allow-keyless` setting, and the public key requires additional client-side verification for example using FIDO2 or GPG. This is due to insufficient validation procedures of the public key step during SSH request handshake, granting unauthorized access if the keyboard-interaction mode is utilized. An attacker could exploit this vulnerability by presenting manipulated SSH requests using keyboard-interactive authentication mode. This could potentially result in unauthorized access to the Soft Serve. Users should upgrade to the latest Soft Serve version `v0.6.2` to receive the patch for this issue. To workaround this vulnerability without upgrading, users can temporarily disable Keyboard-Interactive SSH Authentication using the `allow-keyless` setting.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-43809?

3 open source packages ship an affected version, including github.com/charmbracelet/soft-serve. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.6.2 |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.6.2 |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.6.2 |

Products: Charm Soft Serve.

## How do I fix CVE-2023-43809?

Upgrade github.com/charmbracelet/soft-serve to 0.6.2 or later.

## Is CVE-2023-43809 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-43809 exists.

## Other vulnerabilities in charmbracelet soft-serve

- [CVE-2026-30832](https://insights.sbomify.com/CVE-2026-30832/): Soft Serve: SSRF via unvalidated LFS endpoint in repo import (critical 9.1)
- [CVE-2025-64522](https://insights.sbomify.com/CVE-2025-64522/): Soft Serve is vulnerable to SSRF through its Webhooks (critical 9.1)
- [CVE-2026-24058](https://insights.sbomify.com/CVE-2026-24058/): Soft Serve has Critical Authentication Bypass (high 8.1)
- [CVE-2026-33353](https://insights.sbomify.com/CVE-2026-33353/): Soft Serve: Authenticated repo import can clone server-local private repositories (high 7.1)
- [CVE-2026-22253](https://insights.sbomify.com/CVE-2026-22253/): Soft Serve is missing an authorization check in LFS lock deletion (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-43809 and fix it if it is affected.

What it is: CVE-2023-43809 is a high-severity authentication bypass vulnerability in charmbracelet soft-serve, published on 4 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-43809 exists.

Affected packages and fixed versions:
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.6.2
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.6.2
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-43809/ (Markdown: https://insights.sbomify.com/CVE-2023-43809/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-43809
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-43809
- OSV: https://osv.dev/vulnerability/CVE-2023-43809

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-43809/
Summaries are generated and may contain mistakes; the official description above is the record.
