# CVE-2023-43810: opentelemetry-instrumentation Denial of Service vulnerability due to unbound cardinality metrics

> Attackers can cause memory exhaustion in instrumented applications by sending requests with random, long HTTP methods, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2023
- **Updated:** 19 Sep 2024
- **Also known as:** GHSA-5rv5-6h4r-h22v, PYSEC-2026-1752, ROOT-APP-PYPI-CVE-2023-43810

## What is CVE-2023-43810?

CVE-2023-43810 is a high-severity denial of service vulnerability in open-telemetry opentelemetry-python-contrib, published on 6 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenTelemetry, also known as OTel for short, is a vendor-neutral open-source Observability framework for instrumenting, generating, collecting, and exporting telemetry data such as traces, metrics, logs. Autoinstrumentation out of the box adds the label `http_method` that has unbound cardinality. It leads to the server's potential memory exhaustion when many malicious requests are sent. HTTP method for requests can be easily set by an attacker to be random and long. In order to be affected program has to be instrumented for HTTP handlers and does not filter any unknown HTTP methods on the level of CDN, LB, previous middleware, etc. This issue has been patched in version 0.41b0.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-43810?

3 open source packages ship an affected version, including opentelemetry-instrumentation. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opentelemetry-instrumentation` | PyPI | All versions | 0.41b0 |
| `opentelemetry-instrumentation` | PyPI | All versions | 0.41b0 |
| `opentelemetry-instrumentation` | PyPI | All versions | 0.41b0 |

Products: Opentelemetry Opentelemetry.

## How do I fix CVE-2023-43810?

Upgrade opentelemetry-instrumentation to 0.41b0 or later.

## Is CVE-2023-43810 being exploited?

There is no known exploitation of CVE-2023-43810 in the wild and no public exploit code.

## Other vulnerabilities in open-telemetry opentelemetry-python-contrib

- [CVE-2026-29181](https://insights.sbomify.com/CVE-2026-29181/): OpenTelemetry-Go multi-value `baggage` header extraction causes excessive allocations (remote dos amplification) (high 7.5)
- [CVE-2023-47108](https://insights.sbomify.com/CVE-2023-47108/): DoS vulnerability in otelgrpc (uncontrolled resource consumption) due to unbound cardinality metrics (high 7.5)
- [CVE-2023-45142](https://insights.sbomify.com/CVE-2023-45142/): OpenTelemetry-Go Contrib has DoS vulnerability in otelhttp due to unbound cardinality metrics (high 7.5)
- [CVE-2026-39883](https://insights.sbomify.com/CVE-2026-39883/): opentelemetry-go: BSD kenv command not using absolute path enables PATH hijacking (high 7.3)
- [CVE-2026-24051](https://insights.sbomify.com/CVE-2026-24051/): OpenTelemetry-Go Affected by Arbitrary Code Execution via PATH Hijacking (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-43810 and fix it if it is affected.

What it is: CVE-2023-43810 is a high-severity denial of service vulnerability in open-telemetry opentelemetry-python-contrib, published on 6 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-43810 in the wild and no public exploit code.

Affected packages and fixed versions:
- opentelemetry-instrumentation (PyPI): affected all versions; fixed in 0.41b0
- opentelemetry-instrumentation (PyPI): affected all versions; fixed in 0.41b0
- opentelemetry-instrumentation (PyPI): affected all versions; fixed in 0.41b0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-43810/ (Markdown: https://insights.sbomify.com/CVE-2023-43810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-43810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-43810
- OSV: https://osv.dev/vulnerability/CVE-2023-43810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-43810/
Summaries are generated and may contain mistakes; the official description above is the record.
