CVE-2023-43826 Apache Guacamole: Integer overflow in handling of VNC image buffers

High 7.5 Published Updated

A malicious VNC server can trigger an integer overflow in Apache Guacamole, leading to memory corruption and arbitrary code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-43826?

CVE-2023-43826 is a high-severity vulnerability in Apache Guacamole, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process.

Users are recommended to upgrade to version 1.5.4, which fixes this issue.

Weakness: CWE-190

Which versions are affected by CVE-2023-43826?

2 open source packages ship an affected version, including guacamole and guacamole-server. It affects 1 product.

PackageAffectedFixed in
guacamole BitnamiAll versions1.5.3
guacamole-server BitnamiAll versions1.5.3

Products include Apache Guacamole.

How do I fix CVE-2023-43826?

Upgrade guacamole to 1.5.3 or later.

Is CVE-2023-43826 being exploited?

There is no known exploitation of CVE-2023-43826 in the wild and no public exploit code.

Sources

Also known as BIT-guacamole-2023-43826, BIT-guacamole-server-2023-43826, GHSA-hhj4-xc5f-6f87, UBUNTU-CVE-2023-43826.

Is CVE-2023-43826 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free