{"answers":{"affected":"2 open source packages ship an affected version, including guacamole and guacamole-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-43826 in the wild and no public exploit code.","fix":"Upgrade guacamole to 1.5.3 or later.","what":"CVE-2023-43826 is a high-severity vulnerability in Apache Guacamole, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-43826 and fix it if it is affected.\n\nWhat it is: CVE-2023-43826 is a high-severity vulnerability in Apache Guacamole, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-43826 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- guacamole (Bitnami): affected all versions; fixed in 1.5.3\n- guacamole-server (Bitnami): affected all versions; fixed in 1.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-43826/ (Markdown: https://insights.sbomify.com/CVE-2023-43826/index.md)","id":"CVE-2023-43826","markdown":"https://insights.sbomify.com/CVE-2023-43826/index.md","name":"CVE-2023-43826","record":{"aliases":["BIT-guacamole-2023-43826","BIT-guacamole-server-2023-43826","GHSA-hhj4-xc5f-6f87","UBUNTU-CVE-2023-43826"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Remote desktop gateway","requires_auth":"low_privilege","summary":"A malicious VNC server can trigger an integer overflow in Apache Guacamole, leading to memory corruption and arbitrary code execution.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"guacamole","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process.\n\nUsers are recommended to upgrade to version 1.5.4, which fixes this issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Guacamole: Integer overflow in handling of VNC image buffers","id":"CVE-2023-43826","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"integer_overflow","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Subrion CMS Cross-site Scripting vulnerability in /panel/languages","id":"CVE-2023-43828"},"packages":[{"ecosystem":"Bitnami","fixed":["1.5.3"],"introduced":["0"],"last_affected":[],"package":"guacamole","purl":"pkg:bitnami/guacamole","source":"BIT-guacamole-2023-43826"},{"ecosystem":"Bitnami","fixed":["1.5.3"],"introduced":["0"],"last_affected":[],"package":"guacamole-server","purl":"pkg:bitnami/guacamole-server","source":"BIT-guacamole-server-2023-43826"}],"prev":{"headline":"Path traversal in Shihonkanri Plus","id":"CVE-2023-43825"},"products":["Apache Guacamole"],"published":"2023-12-19","related":[{"cvss_score":8.8,"headline":"Improper validation of SAML responses","id":"CVE-2021-43999","kev_date_added":null,"published":"2022-01-11"},{"cvss_score":8.1,"headline":"Apache Guacamole Race Condition vulnerability","id":"CVE-2017-3158","kev_date_added":null,"published":"2018-01-18"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2019-19603","kev_date_added":null,"published":"2019-12-09"},{"cvss_score":7.5,"headline":"Missing Encryption of Sensitive Data in Apache Guacamole","id":"CVE-2018-1340","kev_date_added":null,"published":"2019-02-07"},{"cvss_score":6.8,"headline":"Apache Guacamole: Improper input validation of console codes","id":"CVE-2024-35164","kev_date_added":null,"published":"2025-07-02"},{"cvss_score":6.8,"headline":"Apache Guacamole: Use-after-free in handling of RDP audio input buffer","id":"CVE-2023-30576","kev_date_added":null,"published":"2023-06-07"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-25","vendors":["Apache Software Foundation"]},"summary":"A malicious VNC server can trigger an integer overflow in Apache Guacamole, leading to memory corruption and arbitrary code execution.","url":"https://insights.sbomify.com/CVE-2023-43826/"}