# CVE-2023-43826: Apache Guacamole: Integer overflow in handling of VNC image buffers

> A malicious VNC server can trigger an integer overflow in Apache Guacamole, leading to memory corruption and arbitrary code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2023
- **Updated:** 25 Feb 2026
- **Also known as:** BIT-guacamole-2023-43826, BIT-guacamole-server-2023-43826, GHSA-hhj4-xc5f-6f87, UBUNTU-CVE-2023-43826

## What is CVE-2023-43826?

CVE-2023-43826 is a high-severity vulnerability in Apache Guacamole, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process.

Users are recommended to upgrade to version 1.5.4, which fixes this issue.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2023-43826?

2 open source packages ship an affected version, including guacamole and guacamole-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guacamole` | Bitnami | All versions | 1.5.3 |
| `guacamole-server` | Bitnami | All versions | 1.5.3 |

Products: Apache Guacamole.

## How do I fix CVE-2023-43826?

Upgrade guacamole to 1.5.3 or later.

## Is CVE-2023-43826 being exploited?

There is no known exploitation of CVE-2023-43826 in the wild and no public exploit code.

## Other vulnerabilities in Apache Guacamole

- [CVE-2021-43999](https://insights.sbomify.com/CVE-2021-43999/): Improper validation of SAML responses (high 8.8)
- [CVE-2017-3158](https://insights.sbomify.com/CVE-2017-3158/): Apache Guacamole Race Condition vulnerability (high 8.1)
- [CVE-2019-19603](https://insights.sbomify.com/CVE-2019-19603/): Null dereference in n/a (high 7.5)
- [CVE-2018-1340](https://insights.sbomify.com/CVE-2018-1340/): Missing Encryption of Sensitive Data in Apache Guacamole (high 7.5)
- [CVE-2024-35164](https://insights.sbomify.com/CVE-2024-35164/): Apache Guacamole: Improper input validation of console codes (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-43826 and fix it if it is affected.

What it is: CVE-2023-43826 is a high-severity vulnerability in Apache Guacamole, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-43826 in the wild and no public exploit code.

Affected packages and fixed versions:
- guacamole (Bitnami): affected all versions; fixed in 1.5.3
- guacamole-server (Bitnami): affected all versions; fixed in 1.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-43826/ (Markdown: https://insights.sbomify.com/CVE-2023-43826/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-43826
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-43826
- OSV: https://osv.dev/vulnerability/CVE-2023-43826

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-43826/
Summaries are generated and may contain mistakes; the official description above is the record.
