{"answers":{"affected":"2 open source packages ship an affected version, including postcss. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-44270 in the wild and no public exploit code.","fix":"Upgrade postcss to 8.4.31 or later.","what":"CVE-2023-44270 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-44270 and fix it if it is affected.\n\nWhat it is: CVE-2023-44270 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-44270 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postcss (npm): affected all versions; fixed in 8.4.31\n- postcss (npm): affected all versions; fixed in 8.4.31\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-44270/ (Markdown: https://insights.sbomify.com/CVE-2023-44270/index.md)","id":"CVE-2023-44270","markdown":"https://insights.sbomify.com/CVE-2023-44270/index.md","name":"CVE-2023-44270","record":{"aliases":["CLSA-2026-1777509599","CLSA-2026-1786374683","DEBIAN-CVE-2023-44270","GHSA-7fh5-64p2-3v2j","MINI-g7wj-4589-j6j7","ROOT-APP-NPM-CVE-2023-44270","UBUNTU-CVE-2023-44270"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostCSS library","requires_auth":"none","summary":"Attackers can inject malicious CSS via comments in PostCSS, potentially leading to XSS when processed by linters.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"postcss","vendor":"postcss"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"An issue was discovered in PostCSS before 8.4.31. The vulnerability affects linters using PostCSS to parse external untrusted CSS. An attacker can prepare CSS in such a way that it will contains parts parsed by PostCSS as a CSS comment. After processing by PostCSS, it will be included in the PostCSS output in CSS nodes (rules, properties) despite being included in a comment.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PostCSS line return parsing error","id":"CVE-2023-44270","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"Pillow Denial of Service vulnerability","id":"CVE-2023-44271"},"packages":[{"ecosystem":"npm","fixed":["8.4.31"],"introduced":["0"],"last_affected":[],"package":"postcss","purl":null,"source":"GHSA-7fh5-64p2-3v2j"},{"ecosystem":"npm","fixed":["8.4.31"],"introduced":["0"],"last_affected":[],"package":"postcss","purl":"pkg:npm/postcss","source":"GHSA-7fh5-64p2-3v2j"}],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.","id":"CVE-2023-44268"},"products":["n/a"],"published":"2023-09-29","related":[{"cvss_score":7.5,"headline":"PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments","id":"CVE-2026-45623","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":6.3,"headline":"PostCSS: incomplete fix of GHSA-6g55-p6wh-862q — attacker-controlled sourceMappingURL reads arbitrary .map files when `from` is unset","id":"CVE-2026-69153","kev_date_added":null,"published":"2026-08-03"},{"cvss_score":5.3,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23382","kev_date_added":null,"published":"2021-04-26"},{"cvss_score":5.3,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23368","kev_date_added":null,"published":"2021-04-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["n/a"]},"summary":"Attackers can inject malicious CSS via comments in PostCSS, potentially leading to XSS when processed by linters.","url":"https://insights.sbomify.com/CVE-2023-44270/"}