# CVE-2023-44270: PostCSS line return parsing error

> Attackers can inject malicious CSS via comments in PostCSS, potentially leading to XSS when processed by linters.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2023
- **Updated:** 3 Nov 2025
- **Also known as:** CLSA-2026-1777509599, CLSA-2026-1786374683, DEBIAN-CVE-2023-44270, GHSA-7fh5-64p2-3v2j, MINI-g7wj-4589-j6j7, ROOT-APP-NPM-CVE-2023-44270, UBUNTU-CVE-2023-44270

## What is CVE-2023-44270?

CVE-2023-44270 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in PostCSS before 8.4.31. The vulnerability affects linters using PostCSS to parse external untrusted CSS. An attacker can prepare CSS in such a way that it will contains parts parsed by PostCSS as a CSS comment. After processing by PostCSS, it will be included in the PostCSS output in CSS nodes (rules, properties) despite being included in a comment.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-44270?

2 open source packages ship an affected version, including postcss. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postcss` | npm | All versions | 8.4.31 |
| `postcss` | npm | All versions | 8.4.31 |

Products: Postcss Postcss.

## How do I fix CVE-2023-44270?

Upgrade postcss to 8.4.31 or later.

## Is CVE-2023-44270 being exploited?

There is no known exploitation of CVE-2023-44270 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-45623](https://insights.sbomify.com/CVE-2026-45623/): PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments (high 7.5)
- [CVE-2026-69153](https://insights.sbomify.com/CVE-2026-69153/): PostCSS: incomplete fix of GHSA-6g55-p6wh-862q — attacker-controlled sourceMappingURL reads arbitrary .map files when `from` is unset (medium 6.3)
- [CVE-2021-23382](https://insights.sbomify.com/CVE-2021-23382/): Regular Expression Denial of Service (ReDoS) (medium 5.3)
- [CVE-2021-23368](https://insights.sbomify.com/CVE-2021-23368/): Regular Expression Denial of Service (ReDoS) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-44270 and fix it if it is affected.

What it is: CVE-2023-44270 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-44270 in the wild and no public exploit code.

Affected packages and fixed versions:
- postcss (npm): affected all versions; fixed in 8.4.31
- postcss (npm): affected all versions; fixed in 8.4.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-44270/ (Markdown: https://insights.sbomify.com/CVE-2023-44270/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-44270
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-44270
- OSV: https://osv.dev/vulnerability/CVE-2023-44270

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-44270/
Summaries are generated and may contain mistakes; the official description above is the record.
