# CVE-2023-44273: Duplicate Advisory: Consensys gnark-crypto allows Signature Malleability

> Attackers can exploit signature malleability in gnark-crypto by bypassing interval checks during EdDSA and ECDSA signature deserialization.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2023
- **Updated:** 23 Sep 2024
- **Also known as:** GHSA-9xfq-8j3r-xp5g, GHSA-fr8m-434r-g3xp, GO-2023-2096, GO-2025-4027

## What is CVE-2023-44273?

CVE-2023-44273 is a critical unsafe deserialization vulnerability in n/a, published on 28 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Consensys gnark-crypto through 0.11.2 allows Signature Malleability. This occurs because deserialisation of EdDSA and ECDSA signatures does not ensure that the data is in a certain interval.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-44273?

8 open source packages ship an affected version, including github.com/consensys/gnark-crypto and github.com/Consensys/gnark-crypto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/consensys/gnark-crypto` | Go | All versions | 0.12.0 |
| `github.com/consensys/gnark-crypto` | Go | All versions | 0.12.0 |
| `github.com/consensys/gnark-crypto` | Go | All versions | 0.12.0 |
| `github.com/consensys/gnark-crypto` | Go | All versions | 0.12.0 |
| `github.com/consensys/gnark-crypto` | Go | All versions | 0.12.0 |
| `github.com/consensys/gnark-crypto` | Go | All versions | 0.12.0 |
| `github.com/Consensys/gnark-crypto` | Go | All versions | 0.12.0 |
| `github.com/Consensys/gnark-crypto` | Go | All versions | 0.12.0 |

Products: Consensys Gnark-Crypto.

## How do I fix CVE-2023-44273?

Upgrade github.com/consensys/gnark-crypto to 0.12.0 or later.

## Is CVE-2023-44273 being exploited?

There is no known exploitation of CVE-2023-44273 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-45039](https://insights.sbomify.com/CVE-2024-45039/): gnark's Groth16 commitment extension unsound for more than one commitment (medium 6.2)
- [CVE-2024-45040](https://insights.sbomify.com/CVE-2024-45040/): gnark's commitments to private witnesses in Groth16 as implemented break zero-knowledge property (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-44273 and fix it if it is affected.

What it is: CVE-2023-44273 is a critical unsafe deserialization vulnerability in n/a, published on 28 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-44273 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/consensys/gnark-crypto (Go): affected all versions; fixed in 0.12.0
- github.com/consensys/gnark-crypto (Go): affected all versions; fixed in 0.12.0
- github.com/consensys/gnark-crypto (Go): affected all versions; fixed in 0.12.0
- github.com/consensys/gnark-crypto (Go): affected all versions; fixed in 0.12.0
- github.com/consensys/gnark-crypto (Go): affected all versions; fixed in 0.12.0
- github.com/consensys/gnark-crypto (Go): affected all versions; fixed in 0.12.0
- github.com/Consensys/gnark-crypto (Go): affected all versions; fixed in 0.12.0
- github.com/Consensys/gnark-crypto (Go): affected all versions; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-44273/ (Markdown: https://insights.sbomify.com/CVE-2023-44273/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-44273
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-44273
- OSV: https://osv.dev/vulnerability/CVE-2023-44273

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-44273/
Summaries are generated and may contain mistakes; the official description above is the record.
