{"answers":{"affected":"3 open source packages ship an affected version, including github.com/apache/servicecomb-service-center. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-44312 in the wild and no public exploit code.","fix":"Upgrade github.com/apache/servicecomb-service-center to 2.2.0 or later.","what":"CVE-2023-44312 is a medium-severity vulnerability in Apache ServiceComb Service-Center, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-44312 and fix it if it is affected.\n\nWhat it is: CVE-2023-44312 is a medium-severity vulnerability in Apache ServiceComb Service-Center, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-44312 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/apache/servicecomb-service-center (Go): affected all versions; no fix listed\n- github.com/apache/servicecomb-service-center (Go): affected all versions; fixed in 2.2.0\n- github.com/apache/servicecomb-service-center (Go): affected all versions; fixed in 2.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-44312/ (Markdown: https://insights.sbomify.com/CVE-2023-44312/index.md)","id":"CVE-2023-44312","markdown":"https://insights.sbomify.com/CVE-2023-44312/index.md","name":"CVE-2023-44312","record":{"aliases":["GHSA-r8xp-52mq-rmm8","GO-2024-2496"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Service Center","requires_auth":"none","summary":"An attacker can query all environment variables of the Apache ServiceComb Service-Center server, exposing sensitive configuration data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"servicecomb","vendor":"apache"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Exposure of Sensitive Information to an Unauthorized Actor in Apache ServiceComb Service-Center.This issue affects \n\nApache ServiceComb Service-Center\n\n before 2.1.0 (include).\n\nUsers are recommended to upgrade to version 2.2.0, which fixes the issue.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ServiceComb Service-Center: attacker can query all environment variables of the service-center server","id":"CVE-2023-44312","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"information_disclosure","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Apache ServiceComb Service-Center: attacker can perform SSRF through the frontend API","id":"CVE-2023-44313"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/apache/servicecomb-service-center","purl":"pkg:golang/github.com/apache/servicecomb-service-center","source":"GO-2024-2496"},{"ecosystem":"Go","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"github.com/apache/servicecomb-service-center","purl":null,"source":"GHSA-r8xp-52mq-rmm8"},{"ecosystem":"Go","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"github.com/apache/servicecomb-service-center","purl":"pkg:golang/github.com/apache/servicecomb-service-center","source":"GHSA-r8xp-52mq-rmm8"}],"prev":{"headline":"Liferay Portal and Liferay DXP Vulnerable to XSS via the OAuth2ProviderApplicationRedirect Class","id":"CVE-2023-44311"},"products":["Apache ServiceComb Service-Center"],"published":"2024-01-31","related":[{"cvss_score":7.6,"headline":"Apache ServiceComb Service-Center: attacker can perform SSRF through the frontend API","id":"CVE-2023-44313","kev_date_added":null,"published":"2024-01-31"},{"cvss_score":7.5,"headline":"ServiceComb ServiceCenter Directory Traversal","id":"CVE-2021-21501","kev_date_added":null,"published":"2021-08-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-30","vendors":["Apache Software Foundation"]},"summary":"An attacker can query all environment variables of the Apache ServiceComb Service-Center server, exposing sensitive configuration data.","url":"https://insights.sbomify.com/CVE-2023-44312/"}