# CVE-2023-44312: Apache ServiceComb Service-Center: attacker can query all environment variables of the service-center server

> An attacker can query all environment variables of the Apache ServiceComb Service-Center server, exposing sensitive configuration data.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jan 2024
- **Updated:** 30 May 2025
- **Also known as:** GHSA-r8xp-52mq-rmm8, GO-2024-2496

## What is CVE-2023-44312?

CVE-2023-44312 is a medium-severity vulnerability in Apache ServiceComb Service-Center, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Exposure of Sensitive Information to an Unauthorized Actor in Apache ServiceComb Service-Center.This issue affects 

Apache ServiceComb Service-Center

 before 2.1.0 (include).

Users are recommended to upgrade to version 2.2.0, which fixes the issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-44312?

3 open source packages ship an affected version, including github.com/apache/servicecomb-service-center. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apache/servicecomb-service-center` | Go | All versions | None |
| `github.com/apache/servicecomb-service-center` | Go | All versions | 2.2.0 |
| `github.com/apache/servicecomb-service-center` | Go | All versions | 2.2.0 |

Products: Apache Servicecomb.

## How do I fix CVE-2023-44312?

Upgrade github.com/apache/servicecomb-service-center to 2.2.0 or later.

## Is CVE-2023-44312 being exploited?

There is no known exploitation of CVE-2023-44312 in the wild and no public exploit code.

## Other vulnerabilities in Apache ServiceComb Service-Center

- [CVE-2023-44313](https://insights.sbomify.com/CVE-2023-44313/): Apache ServiceComb Service-Center: attacker can perform SSRF through the frontend API (high 7.6)
- [CVE-2021-21501](https://insights.sbomify.com/CVE-2021-21501/): ServiceComb ServiceCenter Directory Traversal (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-44312 and fix it if it is affected.

What it is: CVE-2023-44312 is a medium-severity vulnerability in Apache ServiceComb Service-Center, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-44312 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apache/servicecomb-service-center (Go): affected all versions; no fix listed
- github.com/apache/servicecomb-service-center (Go): affected all versions; fixed in 2.2.0
- github.com/apache/servicecomb-service-center (Go): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-44312/ (Markdown: https://insights.sbomify.com/CVE-2023-44312/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-44312
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-44312
- OSV: https://osv.dev/vulnerability/CVE-2023-44312

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-44312/
Summaries are generated and may contain mistakes; the official description above is the record.
