CVE-2023-44313 Apache ServiceComb Service-Center: attacker can perform SSRF through the frontend API

High 7.6 Published Updated

Attackers can exploit SSRF in Apache ServiceComb Service-Center to access sensitive server information via crafted requests.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-44313?

CVE-2023-44313 is a high-severity server-side request forgery vulnerability in Apache ServiceComb Service-Center, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Server-Side Request Forgery (SSRF) vulnerability in Apache ServiceComb Service-Center. Attackers can obtain sensitive server information through specially crafted requests.This issue affects Apache ServiceComb before 2.1.0(include).

Users are recommended to upgrade to version 2.2.0, which fixes the issue.

Weakness: CWE-918

Which versions are affected by CVE-2023-44313?

3 open source packages ship an affected version, including github.com/apache/servicecomb-service-center. It affects 1 product.

PackageAffectedFixed in
github.com/apache/servicecomb-service-center GoAll versionsNone
github.com/apache/servicecomb-service-center GoAll versions2.2.0
github.com/apache/servicecomb-service-center GoAll versions2.2.0

Products include Apache Servicecomb.

How do I fix CVE-2023-44313?

Upgrade github.com/apache/servicecomb-service-center to 2.2.0 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2023-44313 being exploited?

There is no known exploitation of CVE-2023-44313 in the wild and no public exploit code.

Sources

Also known as GHSA-9xc9-xq7w-vpcr, GO-2024-2495.

Is CVE-2023-44313 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free