{"answers":{"affected":"3 open source packages ship an affected version, including github.com/apache/servicecomb-service-center. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-44313 in the wild and no public exploit code.","fix":"Upgrade github.com/apache/servicecomb-service-center to 2.2.0 or later.","what":"CVE-2023-44313 is a high-severity server-side request forgery vulnerability in Apache ServiceComb Service-Center, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-44313 and fix it if it is affected.\n\nWhat it is: CVE-2023-44313 is a high-severity server-side request forgery vulnerability in Apache ServiceComb Service-Center, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-44313 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/apache/servicecomb-service-center (Go): affected all versions; no fix listed\n- github.com/apache/servicecomb-service-center (Go): affected all versions; fixed in 2.2.0\n- github.com/apache/servicecomb-service-center (Go): affected all versions; fixed in 2.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-44313/ (Markdown: https://insights.sbomify.com/CVE-2023-44313/index.md)","id":"CVE-2023-44313","markdown":"https://insights.sbomify.com/CVE-2023-44313/index.md","name":"CVE-2023-44313","record":{"aliases":["GHSA-9xc9-xq7w-vpcr","GO-2024-2495"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"ServiceComb Service-Center","requires_auth":"none","summary":"Attackers can exploit SSRF in Apache ServiceComb Service-Center to access sensitive server information via crafted requests.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"servicecomb","vendor":"apache"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Server-Side Request Forgery (SSRF) vulnerability in Apache ServiceComb Service-Center. Attackers can obtain sensitive server information through specially crafted requests.This issue affects Apache ServiceComb before 2.1.0(include).\n\nUsers are recommended to upgrade to version 2.2.0, which fixes the issue.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ServiceComb Service-Center: attacker can perform SSRF through the frontend API","id":"CVE-2023-44313","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"ssrf","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-site scripting in SINEC NMS","id":"CVE-2023-44315"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/apache/servicecomb-service-center","purl":"pkg:golang/github.com/apache/servicecomb-service-center","source":"GO-2024-2495"},{"ecosystem":"Go","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"github.com/apache/servicecomb-service-center","purl":null,"source":"GHSA-9xc9-xq7w-vpcr"},{"ecosystem":"Go","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"github.com/apache/servicecomb-service-center","purl":"pkg:golang/github.com/apache/servicecomb-service-center","source":"GHSA-9xc9-xq7w-vpcr"}],"prev":{"headline":"Apache ServiceComb Service-Center: attacker can query all environment variables of the service-center server","id":"CVE-2023-44312"},"products":["Apache ServiceComb Service-Center"],"published":"2024-01-31","related":[{"cvss_score":7.5,"headline":"ServiceComb ServiceCenter Directory Traversal","id":"CVE-2021-21501","kev_date_added":null,"published":"2021-08-10"},{"cvss_score":5.8,"headline":"Apache ServiceComb Service-Center: attacker can query all environment variables of the service-center server","id":"CVE-2023-44312","kev_date_added":null,"published":"2024-01-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers can exploit SSRF in Apache ServiceComb Service-Center to access sensitive server information via crafted requests.","url":"https://insights.sbomify.com/CVE-2023-44313/"}