# CVE-2023-44313: Apache ServiceComb Service-Center: attacker can perform SSRF through the frontend API

> Attackers can exploit SSRF in Apache ServiceComb Service-Center to access sensitive server information via crafted requests.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Jan 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-9xc9-xq7w-vpcr, GO-2024-2495

## What is CVE-2023-44313?

CVE-2023-44313 is a high-severity server-side request forgery vulnerability in Apache ServiceComb Service-Center, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Server-Side Request Forgery (SSRF) vulnerability in Apache ServiceComb Service-Center. Attackers can obtain sensitive server information through specially crafted requests.This issue affects Apache ServiceComb before 2.1.0(include).

Users are recommended to upgrade to version 2.2.0, which fixes the issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-44313?

3 open source packages ship an affected version, including github.com/apache/servicecomb-service-center. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apache/servicecomb-service-center` | Go | All versions | None |
| `github.com/apache/servicecomb-service-center` | Go | All versions | 2.2.0 |
| `github.com/apache/servicecomb-service-center` | Go | All versions | 2.2.0 |

Products: Apache Servicecomb.

## How do I fix CVE-2023-44313?

Upgrade github.com/apache/servicecomb-service-center to 2.2.0 or later.

## Is CVE-2023-44313 being exploited?

There is no known exploitation of CVE-2023-44313 in the wild and no public exploit code.

## Other vulnerabilities in Apache ServiceComb Service-Center

- [CVE-2021-21501](https://insights.sbomify.com/CVE-2021-21501/): ServiceComb ServiceCenter Directory Traversal (high 7.5)
- [CVE-2023-44312](https://insights.sbomify.com/CVE-2023-44312/): Apache ServiceComb Service-Center: attacker can query all environment variables of the service-center server (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-44313 and fix it if it is affected.

What it is: CVE-2023-44313 is a high-severity server-side request forgery vulnerability in Apache ServiceComb Service-Center, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-44313 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apache/servicecomb-service-center (Go): affected all versions; no fix listed
- github.com/apache/servicecomb-service-center (Go): affected all versions; fixed in 2.2.0
- github.com/apache/servicecomb-service-center (Go): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-44313/ (Markdown: https://insights.sbomify.com/CVE-2023-44313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-44313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-44313
- OSV: https://osv.dev/vulnerability/CVE-2023-44313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-44313/
Summaries are generated and may contain mistakes; the official description above is the record.
