# CVE-2023-44378: gnark vulnerable to unsoundness in variable comparison/non-unique binary decomposition

> Attackers can exploit unsoundness in variable comparison to create valid but non-unique bit decompositions, bypassing circuit constraints in gnark.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2023
- **Updated:** 19 Sep 2024
- **Also known as:** GHSA-498w-5j49-vqjg, GO-2023-2098

## What is CVE-2023-44378?

CVE-2023-44378 is a high-severity vulnerability in Consensys gnark, published on 9 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

gnark is a zk-SNARK library that offers a high-level API to design circuits. Prior to version 0.9.0, for some in-circuit values, it is possible to construct two valid decomposition to bits. In addition to the canonical decomposition of `a`, for small values there exists a second decomposition for `a+r` (where `r` is the modulus the values are being reduced by). The second decomposition was possible due to overflowing the field where the values are defined. Upgrading to version 0.9.0 should fix the issue without needing to change the calls to value comparison methods.

Weakness: CWE-697 (Incorrect Comparison), CWE-191 (Integer Underflow (Wrap or Wraparound))

## Which versions are affected by CVE-2023-44378?

3 open source packages ship an affected version, including github.com/consensys/gnark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/consensys/gnark` | Go | All versions | 0.9.0 |
| `github.com/consensys/gnark` | Go | All versions | 0.9.0 |
| `github.com/consensys/gnark` | Go | All versions | 0.9.0 |

Products: Consensys Gnark.

## How do I fix CVE-2023-44378?

Upgrade github.com/consensys/gnark to 0.9.0 or later.

## Is CVE-2023-44378 being exploited?

There is no known exploitation of CVE-2023-44378 in the wild and no public exploit code.

## Other vulnerabilities in Consensys gnark

- [CVE-2025-57801](https://insights.sbomify.com/CVE-2025-57801/): gnark is vulnerable to signature malleability in EdDSA and ECDSA due to missing scalar checks (high 8.6)
- [CVE-2025-58157](https://insights.sbomify.com/CVE-2025-58157/): gnark affected by denial of service when computing scalar multiplication using fake-GLV algorithm (high 7.5)
- [CVE-2024-50354](https://insights.sbomify.com/CVE-2024-50354/): Out-of-memory during deserialization with crafted inputs (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-44378 and fix it if it is affected.

What it is: CVE-2023-44378 is a high-severity vulnerability in Consensys gnark, published on 9 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-44378 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/consensys/gnark (Go): affected all versions; fixed in 0.9.0
- github.com/consensys/gnark (Go): affected all versions; fixed in 0.9.0
- github.com/consensys/gnark (Go): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-44378/ (Markdown: https://insights.sbomify.com/CVE-2023-44378/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-44378
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-44378
- OSV: https://osv.dev/vulnerability/CVE-2023-44378

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-44378/
Summaries are generated and may contain mistakes; the official description above is the record.
