# CVE-2023-44386: Incorrect request error handling triggers server crash in Vapor

> Attackers can crash Vapor servers by sending malformed HTTP requests due to incorrect error handling in the HTTP1 parser.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2023
- **Updated:** 19 Sep 2024
- **Also known as:** GHSA-3mwq-h3g6-ffhm

## What is CVE-2023-44386?

CVE-2023-44386 is a medium-severity denial of service vulnerability in vapor, published on 5 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vapor is an HTTP web framework for Swift. There is a denial of service vulnerability impacting all users of affected versions of Vapor. The HTTP1 error handler closed connections when HTTP parse errors occur instead of passing them on. The issue is fixed as of Vapor release 4.84.2.

Weakness: CWE-696 (Incorrect Behavior Order), CWE-617 (Reachable Assertion), CWE-231 (Improper Handling of Extra Values)

## Which versions are affected by CVE-2023-44386?

2 open source packages ship an affected version, including github.com/vapor/vapor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/vapor/vapor` | SwiftURL | From 4.83.2 | 4.84.2 |
| `github.com/vapor/vapor` | SwiftURL | From 4.83.2 | 4.84.2 |

Products: Vapor Vapor.

## How do I fix CVE-2023-44386?

Upgrade github.com/vapor/vapor to 4.84.2 or later.

## Is CVE-2023-44386 being exploited?

There is no known exploitation of CVE-2023-44386 in the wild and no public exploit code.

## Other vulnerabilities in vapor

- [CVE-2022-31019](https://insights.sbomify.com/CVE-2022-31019/): DoS Vulnerability in URLEncodedFormDecoder in Vapor (high 7.5)
- [CVE-2022-31005](https://insights.sbomify.com/CVE-2022-31005/): Integer Overflow in Vapor's HTTP Range Request (high 7.5)
- [CVE-2024-21631](https://insights.sbomify.com/CVE-2024-21631/): Integer overflow in URI leading to potential host spoofing (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-44386 and fix it if it is affected.

What it is: CVE-2023-44386 is a medium-severity denial of service vulnerability in vapor, published on 5 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-44386 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/vapor/vapor (SwiftURL): affected from 4.83.2; fixed in 4.84.2
- github.com/vapor/vapor (SwiftURL): affected from 4.83.2; fixed in 4.84.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-44386/ (Markdown: https://insights.sbomify.com/CVE-2023-44386/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-44386
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-44386
- OSV: https://osv.dev/vulnerability/CVE-2023-44386

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-44386/
Summaries are generated and may contain mistakes; the official description above is the record.
