CVE-2023-44401 Silverstripe GraqhQL's view permissions are bypassed for paginated lists of ORM data
Attackers can bypass view permissions to read unauthorized ORM data in paginated GraphQL queries within Silverstripe CMS.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-44401?
CVE-2023-44401 is a medium-severity missing authorization vulnerability in silverstripe-graphql, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Silverstripe CMS GraphQL Server serves Silverstripe data as GraphQL representations. In versions 4.0.0 prior to 4.3.7 and 5.0.0 prior to 5.1.3, `canView` permission checks are bypassed for ORM data in paginated GraphQL query results where the total number of records is greater than the number of records per page. Note that this also affects GraphQL queries which have a limit applied, even if the query isn’t paginated per se. This has been fixed in versions 4.3.7 and 5.1.3 by ensuring no new records are pulled in from the database after performing `canView` permission checks for each page of results. This may result in some pages in the query results having less than the maximum number of records per page even when there are more pages of results. This behavior is consistent with how pagination works in other areas of Silverstripe CMS, such as in `GridField`, and is a result of having to perform permission checks in PHP rather than in the database directly. One may disable these permission checks by disabling the `CanViewPermission` plugin.
Weakness: CWE-863
Which versions are affected by CVE-2023-44401?
4 open source packages ship an affected version, including silverstripe/graphql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
silverstripe/graphql Packagist | From 4.0.0 | 4.3.7 |
silverstripe/graphql Packagist | From 4.0.0 | 4.3.7 |
silverstripe/graphql Packagist | From 5.0.0 | 5.1.3 |
silverstripe/graphql Packagist | From 5.0.0 | 5.1.3 |
Products include Silverstripe Graphql.
How do I fix CVE-2023-44401?
Upgrade silverstripe/graphql to a fixed version for your release line: 4.3.7 or 5.1.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-44401 being exploited?
There is no known exploitation of CVE-2023-44401 in the wild and no public exploit code.
Other vulnerabilities in silverstripe-graphql
Sources
Also known as GHSA-jgph-w8rh-xf5p.