# CVE-2023-44401: Silverstripe GraqhQL's view permissions are bypassed for paginated lists of ORM data

> Attackers can bypass view permissions to read unauthorized ORM data in paginated GraphQL queries within Silverstripe CMS.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-jgph-w8rh-xf5p

## What is CVE-2023-44401?

CVE-2023-44401 is a medium-severity missing authorization vulnerability in silverstripe-graphql, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Silverstripe CMS GraphQL Server serves Silverstripe data as GraphQL representations. In versions 4.0.0 prior to 4.3.7 and 5.0.0 prior to 5.1.3, `canView` permission checks are bypassed for ORM data in paginated GraphQL query results where the total number of records is greater than the number of records per page. Note that this also affects GraphQL queries which have a limit applied, even if the query isn’t paginated per se. This has been fixed in versions 4.3.7 and 5.1.3 by ensuring no new records are pulled in from the database after performing `canView` permission checks for each page of results. This may result in some pages in the query results having less than the maximum number of records per page even when there are more pages of results. This behavior is consistent with how pagination works in other areas of Silverstripe CMS, such as in `GridField`, and is a result of having to perform permission checks in PHP rather than in the database directly. One may disable these permission checks by disabling the `CanViewPermission` plugin.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-44401?

4 open source packages ship an affected version, including silverstripe/graphql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/graphql` | Packagist | From 4.0.0 | 4.3.7 |
| `silverstripe/graphql` | Packagist | From 4.0.0 | 4.3.7 |
| `silverstripe/graphql` | Packagist | From 5.0.0 | 5.1.3 |
| `silverstripe/graphql` | Packagist | From 5.0.0 | 5.1.3 |

Products: Silverstripe Graphql.

## How do I fix CVE-2023-44401?

Upgrade silverstripe/graphql to a fixed version for your release line: 4.3.7 or 5.1.3.

## Is CVE-2023-44401 being exploited?

There is no known exploitation of CVE-2023-44401 in the wild and no public exploit code.

## Other vulnerabilities in silverstripe-graphql

- [CVE-2023-40180](https://insights.sbomify.com/CVE-2023-40180/): Denial of service vulnerability in silverstripe-graphql via recursive queries (high 7.5)
- [CVE-2023-28104](https://insights.sbomify.com/CVE-2023-28104/): silverstripe/graphql Denial of Service vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-44401 and fix it if it is affected.

What it is: CVE-2023-44401 is a medium-severity missing authorization vulnerability in silverstripe-graphql, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-44401 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/graphql (Packagist): affected from 4.0.0; fixed in 4.3.7
- silverstripe/graphql (Packagist): affected from 4.0.0; fixed in 4.3.7
- silverstripe/graphql (Packagist): affected from 5.0.0; fixed in 5.1.3
- silverstripe/graphql (Packagist): affected from 5.0.0; fixed in 5.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-44401/ (Markdown: https://insights.sbomify.com/CVE-2023-44401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-44401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-44401
- OSV: https://osv.dev/vulnerability/CVE-2023-44401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-44401/
Summaries are generated and may contain mistakes; the official description above is the record.
