# CVE-2023-44402: ASAR Integrity bypass via filetype confusion in electron

> Attackers can bypass ASAR integrity checks on macOS if specific fuses are enabled and they have write access to the app bundle.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-7m48-wc93-9g85

## What is CVE-2023-44402?

CVE-2023-44402 is a medium-severity vulnerability in Electronjs Electron, published on 1 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Electron is an open source framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. This only impacts apps that have the `embeddedAsarIntegrityValidation` and `onlyLoadAppFromAsar` fuses enabled.  Apps without these fuses enabled are not impacted.  This issue is specific to macOS as these fuses are only currently supported on macOS. Specifically this issue can only be exploited if your app is launched from a filesystem the attacker has write access too.  i.e. the ability to edit files inside the `.app` bundle on macOS which these fuses are supposed to protect against. There are no app side workarounds, you must update to a patched version of Electron.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2023-44402?

12 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 22.3.24 |
| `electron` | npm | All versions | 22.3.24 |
| `electron` | npm | From 23.0.0-alpha.1 to 23.3.13 | None |
| `electron` | npm | From 23.0.0-alpha.1 to 23.3.13 | None |
| `electron` | npm | From 24.0.0-alpha.1 | 24.8.3 |
| `electron` | npm | From 24.0.0-alpha.1 | 24.8.3 |
| `electron` | npm | From 25.0.0-alpha.1 | 25.8.1 |
| `electron` | npm | From 25.0.0-alpha.1 | 25.8.1 |
| `electron` | npm | From 26.0.0-alpha.1 | 26.2.1 |
| `electron` | npm | From 26.0.0-alpha.1 | 26.2.1 |
| `electron` | npm | From 27.0.0-alpha.1 | 27.0.0-alpha.7 |
| `electron` | npm | From 27.0.0-alpha.1 | 27.0.0-alpha.7 |

Products: Electronjs Electron.

## How do I fix CVE-2023-44402?

Upgrade electron to a fixed version for your release line: 22.3.24, 24.8.3, 25.8.1 or 26.2.1.

## Is CVE-2023-44402 being exploited?

There is no known exploitation of CVE-2023-44402 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-44402 and fix it if it is affected.

What it is: CVE-2023-44402 is a medium-severity vulnerability in Electronjs Electron, published on 1 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-44402 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 22.3.24
- electron (npm): affected all versions; fixed in 22.3.24
- electron (npm): affected from 23.0.0-alpha.1 up to 23.3.13; no fix listed
- electron (npm): affected from 23.0.0-alpha.1 up to 23.3.13; no fix listed
- electron (npm): affected from 24.0.0-alpha.1; fixed in 24.8.3
- electron (npm): affected from 24.0.0-alpha.1; fixed in 24.8.3
- electron (npm): affected from 25.0.0-alpha.1; fixed in 25.8.1
- electron (npm): affected from 25.0.0-alpha.1; fixed in 25.8.1
- electron (npm): affected from 26.0.0-alpha.1; fixed in 26.2.1
- electron (npm): affected from 26.0.0-alpha.1; fixed in 26.2.1
- electron (npm): affected from 27.0.0-alpha.1; fixed in 27.0.0-alpha.7
- electron (npm): affected from 27.0.0-alpha.1; fixed in 27.0.0-alpha.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-44402/ (Markdown: https://insights.sbomify.com/CVE-2023-44402/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-44402
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-44402
- OSV: https://osv.dev/vulnerability/CVE-2023-44402

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-44402/
Summaries are generated and may contain mistakes; the official description above is the record.
