# CVE-2023-44463: pretix potential IP address spoofing vulnerability

> Attackers can spoof IP addresses by exploiting incorrect header parsing in pretix, bypassing security controls that rely on client IP identification.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2023
- **Updated:** 23 Sep 2024
- **Also known as:** GHSA-j9gq-w73w-9h6c, PYSEC-2023-187

## What is CVE-2023-44463?

CVE-2023-44463 is a medium-severity vulnerability in n/a, published on 2 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in pretix before 2023.7.1. Incorrect parsing of configuration files causes the application to trust unchecked X-Forwarded-For headers even though it has not been configured to do so. This can lead to IP address spoofing by users of the application.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2023-44463?

3 open source packages ship an affected version, including pretix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pretix` | PyPI | All versions | 2023.7.1 |
| `pretix` | PyPI | All versions | 2023.7.1 |
| `pretix` | PyPI | All versions | 2023.7.1 |

Products: Rami Pretix.

## How do I fix CVE-2023-44463?

Upgrade pretix to 2023.7.1 or later.

## Is CVE-2023-44463 being exploited?

There is no known exploitation of CVE-2023-44463 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-44464](https://insights.sbomify.com/CVE-2023-44464/): pretix allows Pillow to parse EPS files (high 7.8)
- [CVE-2023-27891](https://insights.sbomify.com/CVE-2023-27891/): Insufficient Session Expiration in pretix (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-44463 and fix it if it is affected.

What it is: CVE-2023-44463 is a medium-severity vulnerability in n/a, published on 2 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-44463 in the wild and no public exploit code.

Affected packages and fixed versions:
- pretix (PyPI): affected all versions; fixed in 2023.7.1
- pretix (PyPI): affected all versions; fixed in 2023.7.1
- pretix (PyPI): affected all versions; fixed in 2023.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-44463/ (Markdown: https://insights.sbomify.com/CVE-2023-44463/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-44463
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-44463
- OSV: https://osv.dev/vulnerability/CVE-2023-44463

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-44463/
Summaries are generated and may contain mistakes; the official description above is the record.
