{"answers":{"affected":"3 open source packages ship an affected version, including pretix. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-44464 in the wild and no public exploit code.","fix":"Upgrade pretix to 2023.7.2 or later.","what":"CVE-2023-44464 is a high-severity vulnerability in n/a, published on 29 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-44464 and fix it if it is affected.\n\nWhat it is: CVE-2023-44464 is a high-severity vulnerability in n/a, published on 29 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-44464 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pretix (PyPI): affected all versions; fixed in 2023.7.2\n- pretix (PyPI): affected all versions; fixed in 2023.7.2\n- pretix (PyPI): affected all versions; fixed in 2023.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-44464/ (Markdown: https://insights.sbomify.com/CVE-2023-44464/index.md)","id":"CVE-2023-44464","markdown":"https://insights.sbomify.com/CVE-2023-44464/index.md","name":"CVE-2023-44464","record":{"aliases":["GHSA-9jvx-p6mq-fw4v","PYSEC-2026-1801"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Event ticketing platform","requires_auth":"none","summary":"Attackers can exploit EPS file parsing in pretix to potentially execute arbitrary code via malicious uploads.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pretix","vendor":"rami"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"pretix before 2023.7.2 allows Pillow to parse EPS files.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pretix allows Pillow to parse EPS files","id":"CVE-2023-44464","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2023"},"n_packages":3,"n_references":5,"next":{"headline":"Integer overflow in n/a","id":"CVE-2023-44466"},"packages":[{"ecosystem":"PyPI","fixed":["2023.7.2"],"introduced":["0"],"last_affected":[],"package":"pretix","purl":null,"source":"GHSA-9jvx-p6mq-fw4v"},{"ecosystem":"PyPI","fixed":["2023.7.2"],"introduced":["0"],"last_affected":[],"package":"pretix","purl":"pkg:pypi/pretix","source":"GHSA-9jvx-p6mq-fw4v"},{"ecosystem":"PyPI","fixed":["2023.7.2"],"introduced":["0"],"last_affected":[],"package":"pretix","purl":"pkg:pypi/pretix","source":"PYSEC-2026-1801"}],"prev":{"headline":"pretix potential IP address spoofing vulnerability","id":"CVE-2023-44463"},"products":["n/a"],"published":"2023-09-29","related":[{"cvss_score":7.5,"headline":"Insufficient Session Expiration in pretix","id":"CVE-2023-27891","kev_date_added":null,"published":"2023-03-06"},{"cvss_score":5.3,"headline":"pretix potential IP address spoofing vulnerability","id":"CVE-2023-44463","kev_date_added":null,"published":"2023-10-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-23","vendors":["n/a"]},"summary":"Attackers can exploit EPS file parsing in pretix to potentially execute arbitrary code via malicious uploads.","url":"https://insights.sbomify.com/CVE-2023-44464/"}