# CVE-2023-44483: Apache Santuario: Private Key disclosure in debug-log output

> Attackers can read private keys from log files if debug logging is enabled during XML signature generation in Apache Santuario.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Oct 2023
- **Updated:** 3 Nov 2025
- **Also known as:** CLSA-2024-1727136003, DEBIAN-CVE-2023-44483, GHSA-xfrj-6vvc-3xm2, OESA-2025-2380, OESA-2025-2381, OESA-2025-2382, OESA-2025-2383, OESA-2025-2384, OESA-2025-2385, UBUNTU-CVE-2023-44483

## What is CVE-2023-44483?

CVE-2023-44483 is a medium-severity vulnerability in Apache Santuario, published on 20 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

All versions of Apache Santuario - XML Security for Java prior to 2.2.6, 2.3.4, and 3.0.3, when using the JSR 105 API, are vulnerable to an issue where a private key may be disclosed in log files when generating an XML Signature and logging with debug level is enabled. Users are recommended to upgrade to version 2.2.6, 2.3.4, or 3.0.3, which fixes this issue.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2023-44483?

6 open source packages ship an affected version, including org.apache.santuario:xmlsec. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.santuario:xmlsec` | Maven | All versions | 2.2.6 |
| `org.apache.santuario:xmlsec` | Maven | All versions | 2.2.6 |
| `org.apache.santuario:xmlsec` | Maven | From 2.3.0 | 2.3.4 |
| `org.apache.santuario:xmlsec` | Maven | From 2.3.0 | 2.3.4 |
| `org.apache.santuario:xmlsec` | Maven | From 3.0.0 | 3.0.3 |
| `org.apache.santuario:xmlsec` | Maven | From 3.0.0 | 3.0.3 |

Products: Apache Santuario Xml Security for Java.

## How do I fix CVE-2023-44483?

Upgrade org.apache.santuario:xmlsec to a fixed version for your release line: 2.2.6, 2.3.4 or 3.0.3.

## Is CVE-2023-44483 being exploited?

There is no known exploitation of CVE-2023-44483 in the wild and no public exploit code.

## Other vulnerabilities in Apache Santuario

- [CVE-2019-12400](https://insights.sbomify.com/CVE-2019-12400/): Improper input validation in Apache Santuario XML Security for Java (medium 5.5)
- [CVE-2014-8152](https://insights.sbomify.com/CVE-2014-8152/): Improper Input Validation in Apache Santuario XML Security (medium 5.0)
- [CVE-2013-4517](https://insights.sbomify.com/CVE-2013-4517/): Improper Input Validation in Apache Santuario XML Security (medium 4.3)
- [CVE-2013-2172](https://insights.sbomify.com/CVE-2013-2172/): Inefficient Algorithmic Complexity in Apache Santuario XML Security (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-44483 and fix it if it is affected.

What it is: CVE-2023-44483 is a medium-severity vulnerability in Apache Santuario, published on 20 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-44483 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.santuario:xmlsec (Maven): affected all versions; fixed in 2.2.6
- org.apache.santuario:xmlsec (Maven): affected all versions; fixed in 2.2.6
- org.apache.santuario:xmlsec (Maven): affected from 2.3.0; fixed in 2.3.4
- org.apache.santuario:xmlsec (Maven): affected from 2.3.0; fixed in 2.3.4
- org.apache.santuario:xmlsec (Maven): affected from 3.0.0; fixed in 3.0.3
- org.apache.santuario:xmlsec (Maven): affected from 3.0.0; fixed in 3.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-44483/ (Markdown: https://insights.sbomify.com/CVE-2023-44483/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-44483
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-44483
- OSV: https://osv.dev/vulnerability/CVE-2023-44483

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-44483/
Summaries are generated and may contain mistakes; the official description above is the record.
