# CVE-2023-4457: Google Sheets data source plugin for Grafana information disclosure vulnerability

> An attacker can view the Google Sheet API key via unsanitized error messages in the Grafana Google Sheets plugin.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2023
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-37x5-qpm8-53rq, GO-2023-2158

## What is CVE-2023-4457?

CVE-2023-4457 is a medium-severity vulnerability in Grafana google-sheets-datasource, published on 16 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Grafana is an open-source platform for monitoring and observability.

The Google Sheets data source plugin for Grafana, versions 0.9.0 to 1.2.2 are vulnerable to an information disclosure vulnerability.

The plugin did not properly sanitize error messages, making it potentially expose the Google Sheet API-key that is configured for the data source.

This vulnerability was fixed in version 1.2.2.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2023-4457?

3 open source packages ship an affected version, including github.com/grafana/google-sheets-datasource. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grafana/google-sheets-datasource` | Go | From 0.9.0 | 1.2.2 |
| `github.com/grafana/google-sheets-datasource` | Go | From 0.9.0 | 1.2.2 |
| `github.com/grafana/google-sheets-datasource` | Go | From 0.9.0 | 1.2.2 |

Products: Grafana Google Sheets.

## How do I fix CVE-2023-4457?

Upgrade github.com/grafana/google-sheets-datasource to 1.2.2 or later.

## Is CVE-2023-4457 being exploited?

There is no known exploitation of CVE-2023-4457 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-4457 and fix it if it is affected.

What it is: CVE-2023-4457 is a medium-severity vulnerability in Grafana google-sheets-datasource, published on 16 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-4457 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grafana/google-sheets-datasource (Go): affected from 0.9.0; fixed in 1.2.2
- github.com/grafana/google-sheets-datasource (Go): affected from 0.9.0; fixed in 1.2.2
- github.com/grafana/google-sheets-datasource (Go): affected from 0.9.0; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-4457/ (Markdown: https://insights.sbomify.com/CVE-2023-4457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-4457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-4457
- OSV: https://osv.dev/vulnerability/CVE-2023-4457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-4457/
Summaries are generated and may contain mistakes; the official description above is the record.
