# CVE-2023-44796: Cross-site scripting in n/a

> Remote attackers can execute arbitrary scripts to escalate privileges in LimeSurvey via a crafted payload in the general options panel.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-limesurvey-2023-44796, GHSA-8982-pcm5-6hpj

## What is CVE-2023-44796?

CVE-2023-44796 is a medium-severity cross-site scripting vulnerability in Limesurvey Limesurvey, published on 17 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting (XSS) vulnerability in LimeSurvey before version 6.2.9-230925 allows a remote attacker to escalate privileges via a crafted script to the _generaloptions_panel.php component.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-44796?

1 open source package ship an affected version, including limesurvey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `limesurvey` | Bitnami | All versions | 6.2.9 |

Products: Limesurvey Limesurvey.

## How do I fix CVE-2023-44796?

Upgrade limesurvey to 6.2.9 or later.

## Is CVE-2023-44796 being exploited?

There is no known exploitation of CVE-2023-44796 in the wild and no public exploit code.

## Other vulnerabilities in Limesurvey Limesurvey

- [CVE-2025-56422](https://insights.sbomify.com/CVE-2025-56422/): Deserialization in n/a (critical 9.8)
- [CVE-2022-48008](https://insights.sbomify.com/CVE-2022-48008/): File upload in n/a (critical 9.8)
- [CVE-2019-25019](https://insights.sbomify.com/CVE-2019-25019/): SQL injection in n/a (critical 9.8)
- [CVE-2020-11455](https://insights.sbomify.com/CVE-2020-11455/): Path traversal in n/a (critical 9.8)
- [CVE-2019-16184](https://insights.sbomify.com/CVE-2019-16184/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-44796 and fix it if it is affected.

What it is: CVE-2023-44796 is a medium-severity cross-site scripting vulnerability in Limesurvey Limesurvey, published on 17 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-44796 in the wild and no public exploit code.

Affected packages and fixed versions:
- limesurvey (Bitnami): affected all versions; fixed in 6.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-44796/ (Markdown: https://insights.sbomify.com/CVE-2023-44796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-44796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-44796
- OSV: https://osv.dev/vulnerability/CVE-2023-44796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-44796/
Summaries are generated and may contain mistakes; the official description above is the record.
