# CVE-2023-44981: Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication

> Attackers can bypass SASL authentication to join the cluster and modify data if quorum peer authentication is enabled.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2023
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-zookeeper-2023-44981, CLEANSTART-2026-QV72304, DEBIAN-CVE-2023-44981, DLA-3624-1, DSA-5544-1, GHSA-7286-pgfv-vxvh, MINI-8647-2xwr-j9p8, RHLW-2026-09ad7ce59e9c497a, RHLW-2026-0d09faeddb529acc, RHLW-2026-1716354e811dcc0a, RHLW-2026-27cc0b801a76f59b, RHLW-2026-7eac4e5ec1cca641, RHLW-2026-93f19ce4e79ad4f9, RHLW-2026-94bfc0f50bbf8711, RHLW-2026-ee4b4a9ccfe02127, ROOT-APP-MAVEN-CVE-2023-44981, UBUNTU-CVE-2023-44981

## What is CVE-2023-44981?

CVE-2023-44981 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 11 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authorization Bypass Through User-Controlled Key vulnerability in Apache ZooKeeper. If SASL Quorum Peer authentication is enabled in ZooKeeper (quorum.auth.enableSasl=true), the authorization is done by verifying that the instance part in SASL authentication ID is listed in zoo.cfg server list. The instance part in SASL auth ID is optional and if it's missing, like 'eve@EXAMPLE.COM', the authorization check will be skipped. As a result an arbitrary endpoint could join the cluster and begin propagating counterfeit changes to the leader, essentially giving it complete read-write access to the data tree. Quorum Peer authentication is not enabled by default.

Users are recommended to upgrade to version 3.9.1, 3.8.3, 3.7.2, which fixes the issue.

Alternately ensure the ensemble election/quorum communication is protected by a firewall as this will mitigate the issue.

See the documentation for more details on correct cluster administration.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2023-44981?

7 open source packages ship an affected version, including org.apache.zookeeper:zookeeper and zookeeper. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.zookeeper:zookeeper` | Maven | All versions | 3.7.2 |
| `org.apache.zookeeper:zookeeper` | Maven | All versions | 3.7.2 |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.8.0 | 3.8.3 |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.8.0 | 3.8.3 |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.9.0 | 3.9.1 |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.9.0 | 3.9.1 |
| `zookeeper` | Bitnami | All versions to 3.9.0 | 3.7.2, 3.8.3 |

Products: Apache Zookeeper, Debian Debian Linux.

## How do I fix CVE-2023-44981?

Upgrade org.apache.zookeeper:zookeeper to a fixed version for your release line: 3.7.2, 3.8.3 or 3.9.1.

## Is CVE-2023-44981 being exploited?

There is no known exploitation of CVE-2023-44981 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2024-51504](https://insights.sbomify.com/CVE-2024-51504/): Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server (critical 9.1)
- [CVE-2016-5017](https://insights.sbomify.com/CVE-2016-5017/): Memory corruption in n/a (high 8.1)
- [CVE-2026-59739](https://insights.sbomify.com/CVE-2026-59739/): Apache ZooKeeper: Information disclosure via SetWatches reconnect replay (high 7.5)
- [CVE-2026-59969](https://insights.sbomify.com/CVE-2026-59969/): Apache ZooKeeper: Improper validation of certificate with host mismatch in FIPS mode (high 7.5)
- [CVE-2026-79993](https://insights.sbomify.com/CVE-2026-79993/): Missing authorization in Apache ZooKeeper (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-44981 and fix it if it is affected.

What it is: CVE-2023-44981 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 11 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-44981 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.zookeeper:zookeeper (Maven): affected all versions; fixed in 3.7.2
- org.apache.zookeeper:zookeeper (Maven): affected all versions; fixed in 3.7.2
- org.apache.zookeeper:zookeeper (Maven): affected from 3.8.0; fixed in 3.8.3
- org.apache.zookeeper:zookeeper (Maven): affected from 3.8.0; fixed in 3.8.3
- org.apache.zookeeper:zookeeper (Maven): affected from 3.9.0; fixed in 3.9.1
- org.apache.zookeeper:zookeeper (Maven): affected from 3.9.0; fixed in 3.9.1
- zookeeper (Bitnami): affected all versions up to 3.9.0; fixed in 3.7.2, 3.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-44981/ (Markdown: https://insights.sbomify.com/CVE-2023-44981/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-44981
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-44981
- OSV: https://osv.dev/vulnerability/CVE-2023-44981

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-44981/
Summaries are generated and may contain mistakes; the official description above is the record.
