# CVE-2023-45023: TYPO3 extension femanager Broken Access Control vulnerability

> Attackers can bypass permission checks in the femanager extension's invitation component, potentially accessing restricted functionality.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-93j4-v838-8767

## What is CVE-2023-45023?

CVE-2023-45023 is a medium-severity missing authorization vulnerability in TYPO3 femanager, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The femanager extension 7 before 7.2.2 for TYPO3 has Incorrect Access Control: it lacks a check for permissions for the invitation component.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-45023?

2 open source packages ship an affected version, including in2code/femanager.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `in2code/femanager` | Packagist | From 7.0.0 | 7.2.2 |
| `in2code/femanager` | Packagist | From 7.0.0 | 7.2.2 |

## How do I fix CVE-2023-45023?

Upgrade in2code/femanager to 7.2.2 or later.

## Is CVE-2023-45023 being exploited?

There is no known exploitation of CVE-2023-45023 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45023 and fix it if it is affected.

What it is: CVE-2023-45023 is a medium-severity missing authorization vulnerability in TYPO3 femanager, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-45023 in the wild and no public exploit code.

Affected packages and fixed versions:
- in2code/femanager (Packagist): affected from 7.0.0; fixed in 7.2.2
- in2code/femanager (Packagist): affected from 7.0.0; fixed in 7.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45023/ (Markdown: https://insights.sbomify.com/CVE-2023-45023/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45023
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45023
- OSV: https://osv.dev/vulnerability/CVE-2023-45023

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45023/
Summaries are generated and may contain mistakes; the official description above is the record.
